Inkscape 0.92.1 crashes immediately upon starting

Bug #1697681 reported by Sebastian George on 2017-06-13
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
Inkscape
Undecided
Patrick Storz

Bug Description

Whenever I try to run Inkscape, nothing happens for a few seconds, and then I get a popup message that reads, "Inkscape encountered an internal error and will close now."

I am using Windows 10 Home 64-bit.

I get this problem for both 32-bit and 64-bit versions of Inkscape, and I even tried installing each one with both the .exe installer and with the .msi installer. I also get this problem for the portable app version of Inkscape. I also tested with Inkscape 0.91 (32-bit, 64-bit, and portable), but it didn't help.

I found an old forum thread where somebody solved the problem by deleting fonts in Windows that had special characters, but this did not help me.

Running Inkscape as administrator doesn't help.

Installing Inkscape on a different partition (I have a single hard drive with two partitions, and I tried both) doesn't help.

As a non-expert, I've run out of ideas.

Regards,
Sebastian

----
Adding some search terms for future reference (just searched unsuccessfully for *a long time*):
- fontconfig
- FONTCONFIG_FILE
- FONTCONFIG_PATH
- fonts.conf

Fontconfig error: Cannot load default config file

Patrick Storz (ede123) wrote :

This could be the same issue as bug #1508928 / bug #1495386 (they are in fact caused by fonts with certain malformed special characters in their font name).

I recently pushed a fix for that issue. Could you please try if a development build, e.g. https://download.tuxfamily.org/inkscape/win64/inkscape_0.92.x_r15429_win64_MSYS2.7z fixes the bug for you?

If it works running inkscape.com from console should print a warning that mentions the conflicting font.

Hi Eduard,

Thank you for the tip. I tried running the development build that you linked, and unfortunately I got the same problem.

I tried running inkscape.com in the command prompt and it printed

   WARNING: Requested update while update in progress, counter = 2

a bunch of times, followed by:

   Fontconfig error: Cannot load default config file

   Emergency save activated!
   Emergency save completed. Inkscape will close now.

followed by a long list of missing actions that look like

   (inkscape.exe:9284): Gtk-WARNING **: EditSelectAllInAllLayers: missing action EditSelectAllInAllLayers

I'm assuming that the interesting part here is the line mentioning the Fontconfig error. However, it doesn't seem to mention any particular font that's causing problems. Do you have any other ideas?

Regards,
Sebastian

Patrick Storz (ede123) wrote :

Now that sounds strange... (just to be sure: the errors from comment #2 are from the development build or the release version?)

Typically said "default config file" should be the one located at "inkscape\etc\fonts\fonts.conf" (Could you please verify that it exists? Should be fine though when you used the extracted archive.)

Now it could be fontconfig tries to use another (invalid?) fontconfig file. Could you please search "%userprofile%" (the folder containing your Windows user profile, typically "C:\Users\{username}" for any files named "fonts.conf"?

Also: Might you have any other software installed that uses fontconfig and might have created a fonts.conf file / any environment variables with respect to fontconfig?

Last bot not least you could try to delete the fontconfig cache (simply delete the folder "C:\Users\{username}\AppData\Local\fontconfig" and see if it changes anything.

Yes, the errors in comment #2 were from the development build. However, I just tried it in the release version as well and got the same error message.

Just to clarify (since I'm far from an expert when it comes to these things), all I needed to do was extract everything from the .7z file, and then I should be able to immediately try running inkscape.exe, inkscape.com, etc. right? Or is there another step after extracting that I might have missed?

I've checked in both the release version and the development build that the font.conf file is in the folder you mentioned.

Next I searched everywhere (entire hard drive, not just my user folder) for other "fonts.conf" files, and I found several. Two were associated with MiKTeX, one with Steam, and one with a program I use called DemeterPerl. I believe some or all of these also use fontconfig. Anyway, I temporarily renamed all of these "fonts.conf" files to "fonts1.conf", and tried again. Both the release version and the development version continued to give me the same error.

Finally, I deleted the fontconfig cache (plus a second one that I found in the "AppData\Local\MiKTeX" directory), but this sadly didn't not help either.

So I have to thank you for all the information you've provided thus far, and apologize that none of it has helped :(.

Any other ideas?

Regards,
Sebastian

Ok, I just found an old USB stick on which I had previously installed Inkscape Portable (v 0.48). I plugged it in, ran the .exe, and it worked fine!

Out of curiosity, I now installed Inkscape Portable v 0.92 onto the USB stick (when I previously tested Inkscape Portable, I had simply installed it on my computer's internal hard drive), and I got the same problem as before!

So it appears that maybe the problem is with v0.91 and v0.92, since 0.48, at least the portable version, works.

One last follow up for now, I just confirmed that the regular old Inkscape v0.48 works as well.

For now that's what I'll be using (since I have a presentation to finish preparing), but if you come up with any other ideas or things for me to try, I'd be happy to go for it! It would obviously be preferable to use the latest version if possible, but at least I have SOMETHING that works now.

Regards,
Sebastian

Patrick Storz (ede123) wrote :

Regarding your questions: Yes, the 7z archive only has to be extracted, then you can run "inkscape.com/exe" from the folder where you extracted it to. If you're finished with it, delete the extracted folder.

Regarding the issue I'm starting to run out of ideas... but I still got some ;-)

One thing you might try to rule out any path issues (as you mentioned there are some applications using fontconfig on your machine):
* Start a console (cmd.exe)
* execute "set PATH=C:\Windows\system32;C:\Windows"
* run "inkscape.com" (from this console) and see if it works
If any paths with conflicting libraries were added to your PATH variable, this should solve it.

While on console: Could you at some time execute
* "echo %FONTCONFIG_FILE%"
* "echo %FONTCONFIG_PATH%"
It should not return anything, but if those environment variables are set (i.e. output not empty), that would be an issue.

Also to rule out an issue with your settings please rename the folder "C:\Users\{username}\AppData\Roaming\inkscape" to something like "inkscape.bak" and try if it changes anything (it's a long shot but worth trying).

I tried everything that you suggested, and MAYBE we're onto something here. None of your suggestions fixed the issue, but the command "echo %FONTCONFIG_FILE%" returned a fonts.conf files that doesn't appear to actually exist (the last few folders in the path are not actually there).

So I guess the question is: how do I change this variable, and what do I change it to?

Patrick Storz (ede123) wrote :

OK, great, I'm pretty sure that's it!

You can temporarily unset the environment variable on a console to test:
"set FONTCONFIG_FILE="
If you then run inkscape.com from that console I'm pretty sure your problem will be solved.

To delete the environment variable permanently see for example
https://www.techjunkie.com/environment-variables-windows-10/

That fixed it! Hooray!

Thank you for the help Eduard, I envy your Windows know-how!

Patrick Storz (ede123) wrote :

Perfect, glad I could help!

I'm going to close this report as "invalid" (because it was not a bug in Inkscape itself; the issue itself was obviously justified though)

Changed in inkscape:
assignee: nobody → Eduard Braun (eduard-braun2)
status: New → Invalid
Patrick Storz (ede123) on 2017-08-10
tags: added: fonts
description: updated
description: updated
Patrick Storz (ede123) wrote :

I sbmitted a bugreport for the likely culprit (DemeterPerl) upstream:
https://github.com/bruceravel/demeter/issues/51

mray (mrayyyy) wrote :

Closing because what seems to be a duplicate issue was marked "invalid" and seems to not be an actual Inkscape bug in the first place.

Closed by: https://gitlab.com/mray

Ahmad Mubarak (ahmedcrvst) wrote :

I have same problem ("Inkscape encountered an internal error and will close now."), but i don't know how to diagnosis the Issue which can affect the Inkscape. I am using Inkscape release version 0.92.4 (exe installer) on Windows 10 Pro 64 bit.
For your Information, I have installed Inkscape Alpha 1.0. it is normal, but i don't like The User Interface.

Regards,
Ahmedcrvst

tbnorth (terry-n-brown) on 2019-11-29
tags: added: bug-migration
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.