Inkscape: A Vector Drawing Tool

On rotate or duplicate, gradient fill goes unset

Reported by Bug Importer on 2007-10-26
12
Affects Status Importance Assigned to Milestone
Inkscape
Critical
Unassigned

Bug Description

I am using Build 0710231640-dw2 on win2000.
Preferences file and svg attached.

I draw a rectangle and put a simple linear gradient into it. Then if I try
and rotate or duplicate this rectangle the gradient goes black. The
rectangle rotates with the gradient intact and loses the gradient when I
deselect it.
The Affect button second from left is on.

The stable release of 0.45 is working as expected.

Erik

Bug Importer (bug-importer) wrote :
Bug Importer (bug-importer) wrote :

Downloaded 0710261809.7z and its behaviour is exactly the same. Erik

Originator: NO

I cannot reproduce it even with your preferences.xml on Linux.

Erik-erik (erik-erik) wrote :

Originator: NO

I have just downloaded build 0710271459 and it has the same problem for
me.
Erik

Erik-erik (erik-erik) wrote :

Originator: NO

Over the last week I have installed the latest nightly builds and every
one has shown the same behaviour with respect to gradients.
The gradient whether linear or radial can be put onto the object.
Then as soon as anything is done to the object the fill is "unset" and the
object goes black.
Anything includes moving, duplicating, rotating etc.
The rotation etc occurs and then the fill is "unset" when the selector is
released.
My system is win2000.

I have uninstalled and reinstalled the nightly versions until I'm blue in
the face with no change in the behaviour.
The stable version of 0.45 1-1 works as I expect.
I have also installed both stable and build 071030 versions in a laptop
running win2000 and the same problem appears.

I find it hard to believe that no one else has experienced this problem,
and if it is just me then waht the hell am I doing wrong?

In all other respects that I have tested Inkscape appears to be working
normally.
Erik

Originator: NO

ok, i did reproduce it, latest build on xp, but only a few times, in
unpredicable moments. 99% of the time transforming objects with gradients
is ok, but very rarely it indeed goes unset. Couldn't reproduce on linux.
Johan, can you please try if you can at least reproduce this on windows and
if you can, look into what may be wrong?

Elishababayoff (elishababayoff) wrote :

Originator: NO

I have the same problem with win2000.

Johan Engelen (johanengelen) wrote :

Originator: NO

Seems the style is not being copied correctly, or not at all. (from the
example file)
Can't reproduce (haven't tried that much).

Erik-erik (erik-erik) wrote :

Originator: NO

Johan,
I'd like to try and nail this sucker but I'm not a developer. Can you give
me any suggestions on what to try? A test file or a particular sequence of
moves or whatever. Any files/examples or screenshots that you need from me
that might help?
cheers, Erik

Johan Engelen (johanengelen) wrote :

Originator: NO

Assigned to nobody again. I don't know how to help here, since I work on
WinXP. Tracking this down by giving you instructions would take me a month
fulltime :(
Sorry.

Erik-erik (erik-erik) wrote :

Originator: NO

Johan, what a bummer. Especially when it works in the stable version.
Thanks anyway for having a look at it.
Erik

Bug Importer (bug-importer) wrote :

I've just the same problem.

I'm under Windows 2000, and I've tried all dev builds since september.
I can set a gradient on an objet, but any operation (move, resize,
group...) on
the objets unsets the gradient.

The problems isn't there with linux version.

Erik-erik (erik-erik) wrote :

Originator: NO

Fiddling a bit more I have found that when the shape is cloned I can get
it to take a grdaient which can be rotated, moved, scaled etc.

1.Create shape
2.Create clone
3. Cannot create gradient in clone.
4. Create gradient in original
5. Clone gets same gradient
6. Clone can now be rotated/moved scaled etc and the gradient stays with
the
shape.
7. Original goes unset when it is rot/mov/scale etc.

With O.45.1 Grdients can be put into the original and the clone. However
when the original is moved off canvas it loses the gradient. Whenthe clone
goes of canvas it retains its gradient. very strange.
Erik

bbyak (buliabyak) on 2007-12-07
Changed in inkscape:
importance: Medium → Critical
status: New → Confirmed
John Cliff (johncliff) wrote :

Have just spent ten minutes creating dozens of rectangles by rotating/scaling/moving and duplicating and cant get it to do this on either 2000 or XP.
Tried with both my SVN build and the latest off the snapshots page. (Inkscape0712071739.7z)
Not much I can do to help If I cant reproduce.

Ryan Lerch (ryanlerch) wrote :

i tested this about a week ago, on a win2000 machine, and i could reproduce something similar:

as soon as i tried to move a rect with a gradient in it, the gradient disappears. (it is no longer in the def's as far as i can see...)

i also tried it on a windows 2003 server machine, and could not reproduce the bug, and the same with windows XP and windows vista.

when i have access to the windows machines again on monday, i will try with the most recent autobuild of inkscape...

bbyak (buliabyak) wrote :

I _think_ I fixed the windows-only "On rotate or duplicate, gradient fill goes unset" bug. The fix is in rev 16719. Anyone who was suffering from it, please test tomorrow's windows builds and let me know if it works for you.

Ryan Lerch (ryanlerch) wrote :

Quoted from the mailing list:

"Bulia,
I've just tested build 0712162154 and the problem is fixed for me.
Translation, duplication, and rotation all maintain gradient in original and
clone.
Thanks a million for seeing to it. It was really an annoying PITA.
regards, Erik
Erik Halbert"

Changed in inkscape:
status: Confirmed → Fix Released
worms_x (wormsxulla) wrote :

Bulia, you are my hero!

It's fixed for me (Windows 2000 SP 4), it works perfectly, I can rotate, shrink, do * anything * to gradients :)

Thank you a gazillion times, Buila!

Wow wow wow. You developers all rock :)

Build tested: 0712162154

Yes!

It's fixed !

Thanks thanks thanks !

Build tested: 0712162154

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.