Cursor coordinates don't match rulers.

Bug #168831 reported by Bug Importer on 2007-08-15
This bug report is a duplicate of:  Bug #170347: ability to set coordinate origin. Edit Remove
0
Affects Status Importance Assigned to Milestone
Inkscape
Low
Unassigned

Bug Description

Cursor coordinates don't match rulers.
Inkscape 0.45.1

If you modify the ruler origin, the cursor coordinates that display in the
bottom-right of the application GUI aren't adjusted to match the new ruler
positioning.

nightrow (jb-benoit) on 2007-12-18
Changed in inkscape:
importance: Undecided → Low
nightrow (jb-benoit) wrote :

This behavior is indeed confirmed on winXP with inkscape 0.45.1.
The behavior of the 31 december build is even worse, because the ruler aren't updated with an offset in the grid origin (and thus bottom right coordinates aren't updated either).

Changed in inkscape:
status: New → Triaged
Tom Davidson (tjd-mit) wrote :

The ability to change the origin of the document is no longer available in 0.46, so I'm marking this bug invalid. Here's Johan's comments on the change, from the release notes at http://wiki.inkscape.org/wiki/index.php/ReleaseNotes046

"A side effect of removal of old gridcode: apparantly the origin of the desktop rules used to be set to the origin of the grid. I find this strange: specifying a grid origin of (2,2) would have me think the origin would be at ruler location (2,2) instead of (0,0) as it is in 0.45.1. I have commented the grid-origin correction to the ruler range, because now there is not a single grid anymore to correct it for. Isn't there a control somewhere to define the documents origin? Now the ruler origin is set to (0,0)"

If you would like to see control over the co-ordinate system as a feature, please file a new bug as a feature request, ideally giving some use cases so that the developers can see why it would be useful. Thanks!

For reference, the request for the y-axis direction to be switchable (0 at top vs. 0 at bottom) is covered at bug 170049.

Changed in inkscape:
status: Triaged → Incomplete
Tom Davidson (tjd-mit) wrote :

Hi again--no need to file a new feature request: it's already at bug 170347

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers