Inkscape: A Vector Drawing Tool

0.45 on winxp: Mouse not properly captured when using zoom, node or colour picker

Reported by Bug Importer on 2007-07-25
4
Affects Status Importance Assigned to Milestone
Inkscape
Low
Yann Papouin

Bug Description

When you press the mouse button over a window, that window should capture
the mouse until the button is released. Example: when I activate the zoom
tool, and press the left mouse button over the drawing area, and then move
the mouse over a dialog, the zoom rectangle should still be adjusted, and
if I release the mouse button, Inkscape should zoom, even though the mouse
is currently over a dialog window.

Originator: NO

And it works exactly as you describe for me. You need to exactly specify
your version of Inkscape and your OS, otherwise we cannot address this.

Bug Importer (bug-importer) wrote :

0.45 on Windows XP SP2; I'd attach a screenshot if I knew how. Here's some
horrible ASCII art showing the problem:
   _________
  | |
  | |
  | | <--- Zoom rectangle.
  | |
  |_________|
 _______________________
|Dialog window X|
| |
| |\ |
| | \ <--- Mouse pointer.
| \\ |
~ ~

Bug Importer (bug-importer) wrote :

This isn't about mousepointers being displaced. The problem is that the
main Inkscape window doesn't properly capture the mouse when you drag it.
Since I've kept using Inkscape since then, I've discovered that it doesn't
happen with all the tools. On my box, the zoom tool, the node tool and the
colour picker tool appear to be affected.

Please change the summary to:
"Mouse not properly captured when using zoom, node or colour picker
tool."
Thanks for your trouble.

Bug Importer (bug-importer) wrote :

Added note: the zoom tool only does this when dragging a selection
rectangle around nodes, not when dragging actual nodes.

Bug Importer (bug-importer) wrote :

This is not about the mousepointer being displayed in the wrong location;
it moves along with the mousemovements just fine. The problem is that when
using certain tools the main Inkscape window doesn't properly capture the
mouse when you drag it.
On the off chance that the summary given is wrong because people don't
understand what "mouse capture" is:
http://msdn2.microsoft.com/en-us/library/ms645601.aspx#_win32_Mouse_Capture
Apologies in advance if you already know.

nightrow (jb-benoit) on 2007-12-16
Changed in inkscape:
importance: Undecided → Low
John Cliff (johncliff) on 2007-12-27
Changed in inkscape:
status: New → Confirmed
ScislaC (scislac) wrote :

Is this still an issue with 0.46?

Yann Papouin (yann-papouin) wrote :

Yes it's still an issue with Inkscape 0.46+devel r20771

Yann Papouin (yann-papouin) wrote :

Adding a patch to fix this.
But maybe it would be smater to move "SPCanvasItem *grabbed" to SPEventContext and add two functions startGrag and stopGrab.

bbyak (buliabyak) wrote :

thanks for the patch Yann, I will try to test and commit it asap (feel free to poke me if i forget)

poking Bulia ;-)

bbyak (buliabyak) wrote :

thanks for poking, i tested it and committed in 22045, appears safe and conservative enough

Changed in inkscape:
status: Confirmed → Fix Released
Changed in inkscape:
assignee: nobody → Yann Papouin (yann-papouin)
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers