v0.45.1 crashes on startup

Bug #168657 reported by Bug Importer on 2007-05-20
0
Affects Status Importance Assigned to Milestone
Inkscape
Undecided
Michael Wybrow

Bug Description

System: iBook G4, 1,2GHz, 768 MB RAM, 23 GB HD free, Mac OS X 10.4.9
Inkscape v0.45.1 universal and ppc

1. I replaced Inkscape v0.45 by v0.45.1 universal
2. I double-klicked the Inkscape icon
3. X11 started
4. Did other work with other programms
4. Inkscape did not start
5. Closed X11
6. Tried again - X11 starts - waited for 15 minutes - nothing happened
7. Searched for crash log and found it
8. Replaced v0.45.1 universal by v.0.45.1 ppc
9. Tried starting Inkscape but ended up in starting X11 only

10. Downgraded to v0.45 and Inkscape works again.

<email address hidden>

Other attachments

Michael Wybrow (mjwybrow) wrote :

Originator: NO

Could you please take a look what version of X11 you are running (Open
X11, and select About X11). The latest version for OS X 10.4.x is 1.1.3.
My quess is that you have version 1.0 of X11 - a panther version left over
from an upgrade from Panther to Tiger. X11 on Panther didn't supply
/usr/X11R6/lib/libXinerama.1.dylib which is what your provided log shows to
be the problem.

If you are running an older version of X11, could you please install the
version from the "Optional Installs" on the Tiger install DVD. Then run
Software Update to bring that version up to 1.1.3.

Inkscape 0.45.1 should then start okay.

Bug Importer (bug-importer) wrote :

Yes, the bug was me :-(

Since I updated X11 to v1.1.3, Inkscape 0.45.1 starts fine.

<email address hidden>

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Bug attachments