Selected menu item whites out

Bug #168634 reported by Kaushik Ghose on 2007-05-14
2
Affects Status Importance Assigned to Milestone
Inkscape
Low
Unassigned

Bug Description

On Vista Inkscape v.45 menus white out when selected. So if you click on
'File', The file menu drops down and you can see the new menu, but original
'File' is whited out. This is not a problem, since menu items are
accessible, but it is a little annoying

Bug Importer (bug-importer) wrote :

I have this same problem, but this only happend when I installed Inkscape
on Windows Vista. On XP I did not have this problem.

Bug Importer (bug-importer) wrote :

I too have this problem. I just installed Inkscape for the first time. I
have Windows Vista.

S6246001 (s6246001) wrote :

Originator: NO

I experience this on vista. I used the version where i don't have to
install then i didnt face this. But when i used the installed version on
vista i experienced this.

nightrow (jb-benoit) on 2007-12-19
Changed in inkscape:
importance: Undecided → Low
status: New → Confirmed
MaggieLeber (maggie-matrisync) wrote :

Have it on Vista also.

I'd have to disagree that it's "not a problem"...it's a pretty severe usability issue. True, it doesn't render Inkscape completely unusable, but needing to keep the mouse cursor off the menu while finding the item you want sucks a lot. Many people track their gaze with the mouse cursor while navigating menus, and this bug happens not just when you *select* a menu item, but even if you just hover it.

I really think the importance should be escalated above "low".

nightrow (jb-benoit) wrote :

ok, rising it to medium to attract more developpers.

Changed in inkscape:
importance: Low → Medium
Marcin Floryan (mfloryan) wrote :

OK, but is than not more of a GTK+ / Vista issue?

ScislaC (scislac) wrote :

This is a GTK+ issue and is purely superficial, bumping back down to low.

Changed in inkscape:
importance: Medium → Low
Kaushik Ghose (kghose) wrote :

If it was a GTK+ issue, would it happen to GIMP too? It doesn't on my machine

ScislaC (scislac) wrote :

Not if we're not using the same version of GTK+. We supply our own libraries rather than depend on the ones that gimp or pidgin would install. What version of GIMP do you have installed (and what version of GTK was installed with it)?

With this info we can investigate further as to what is different... (it could also be related to the gtk theme as well)

Kaushik Ghose (kghose) wrote :

GIMP 2.4.2 with (I believe) GTK+ 2.12.1
Is there a way I can directly check the version of GTK GIMP is using?

mescalinum (mescalinum) wrote :

here windows7 x64:

issue happens in GIMP 2.6.8 (it looks like gtk+ tries to emulate the windows native colors, but seems like the menu is still a fake menu, not a native windows menu)

does not happen in inkscape 0.47 (still gtk+ has "fake" menus, but with a different color scheme)

also does not happen in seq24 (using gtkmm - there it has even different menu type)

su_v (suv-lp) wrote :

See also more recent reports with Inkscape 0.48:
Bug #630468 “Menu bar items go white when mouse over”

jazzynico (jazzynico) wrote :

Could someone confirm it's fixed on Windows 7 with Inkscape 0.48.2?
The devlibs update that corrected Bug #630468 is very likely to have fixed this one too.

jazzynico (jazzynico) wrote :

Just tested with a virtualboxed W7.
But reproduced with 0.48.1. Not reproduced with 0.48.2.

Changed in inkscape:
milestone: none → 0.48.2
status: Confirmed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers