PostScript Fonts Name

Bug #168456 reported by Bug Importer on 2007-03-08
12
This bug affects 1 person
Affects Status Importance Assigned to Milestone
Inkscape
Medium
Unassigned

Bug Description

I export to EPS a SVG with Arial text.
I choose to not convert it to trace.
EPS file seems like:
   ...
   /Arial-ISOLatin1 /Arial newlatin1font
   ...

Now I want to create PDF via GhostScript or Distiller and both tell me
Arial font is not found!
I resolve it putting the Font PostScript name "ArialMT":
   ...
   /Arial-ISOLatin1 /ArialMT newlatin1font
   ...

and now my PDF has Arial font embedded!

theAdib (theadib) wrote :

known issue.

Changed in inkscape:
importance: Undecided → Medium
status: New → Confirmed
su_v (suv-lp) wrote :

This bug was reported against an older Inkscape version: EPS/PS output in current versions (0.48, 0.48+devel) is based on cairo and always embeds fonts.

Can you confirm that the issue still occurs in current Inkscape 0.48 or recent development builds?

Changed in inkscape:
status: Confirmed → Incomplete
su_v (suv-lp) wrote :

Closing due to lack of feedback. Feel free to reopen if the issue still occurs with embedded and subset fonts (default for the cairo-based PS/EPS export) with current Inkscape versions (>= 0.48.x).

Changed in inkscape:
status: Incomplete → Invalid
Matt (hollandermj) on 2015-05-29
Changed in inkscape:
status: Invalid → New
Matt (hollandermj) wrote :

Using Inkscape 0.48.5 when converting or exporting PDF to plain SVG, there are Post Script (PS) Monotype (MT) or PSMT TrueType font family names are not correctly identified or displayed correctly.

(1.) The first PDF version is produced by MS Word 2010, PDF version 1.6 (Acrobat 7.x), and has the following fonts listed under properties:

Times New Roman
Type: True Type
Encoding: Ansi
Actual Font: TimesNewRomanPSMT
Actual Font Type: True Type

Times New Roman,Bold
Type: TrueType
Encoding: Ansi
Actual Font: TimesNewRomanPS-BoldMT
Actual Font Type: True Type

These are incorrectly identified by Inkscape as font family "Times Roman" instead of "Times New Roman"

Is it because there is a space in the names?

(2.) The second PDF version is created by Adobe PDF Library 11.0, PDF version 1.5 (Acrobat 6.x) and has the following fonts listed under properties:

TimesNewRomanPS-BoldMT
Type: True Type
Encoding: Ansi
Actual Font: TimesNewRomanPS-BoldMT
Actual Font Type: True Type

TimesNewRomanPSMT
Type: True Type
Encoding: Ansi
Actual Font: TimesNewRomanPSMT
Actual Font Type: True Type

These fonts are correctly identified by Inkscape as font family "Times New Roman"

Note: The only reason that I notice or care about the difference between font-family "Times Roman" vs "Times New Roman" is because on my computer I only had the Italic version of "Times Roman" installed so when displaying the resultant SVG file in Microsoft Internet Explorer, MS Visio, the "Times Roman" font is displayed incorrectly in italics since that is the only version of the font installed. However it is interesting that when the SVG is opened in Google Chrome, the "Times Roman" font is displayed correctly, maybe because Google is substituting or using a different source fonts than Microsoft.

Some related information is here on the different font names that can be used when using different PDF creation tools:

Understanding font embedding in a PDF
https://answers.acrobatusers.com/Understanding-font-embedding-in-a-PDF-q142574.aspx

FM 10 "Unusable Fonts"
https://forums.adobe.com/thread/1046403

Could you possibly look into how the font family names are parsed to see if there is some reason why the "Times New Roman" and "Times New Roman,Bold" font names would not be identified as "Times New Roman" and were identified as "Times Roman" instead?

Matt (hollandermj) wrote :

Here are the actual SVG XML attributes:

(1.)

Times New Roman

font-family:Times Roman;-inkscape-font-specification:Times-Roman

(2.)

TimesNewRomanPSMT

font-family:Times New Roman;-inkscape-font-specification:Times-Roman

Note that second version font family is different with "Times New Roman" instead of "Times Roman", however Inkscape font specification is both specified as "Times-Roman"

su_v (suv-lp) wrote :

Proposing to close this report again (see comment #3) - this report never was about "converting or exporting PDF to plain SVG" (i.e. about PDF import) - it was about exporting to PostScript (EPS). There are plenty of other reports which track issues with detecting font names and matching them to installed fonts when importing PDF files.

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers