"Export Bitmap" Title is Confusing

Bug #168446 reported by Bug Importer
24
This bug affects 3 people
Affects Status Importance Assigned to Milestone
Inkscape
Fix Released
Wishlist
John Smith

Bug Description

My Email: jmccann at cs dot cmu dot edu

Using the word "Bitmap" to mean "Raster image", while technically correct,
creates confusions:

Windows: bitmap might be taken to mean BMP format export, while one may
export (e.g.) PNG.

Linux: in traditional X terminology 'bitmap' tends to mean a one-or-zero
image type [e.g. bitmap fonts], with colored images being pixmaps.

I suggest a rename to "raster export", "raster image export" or simply
"export".

Tags: exporting ui
Revision history for this message
towsonu2003 (towsonu2003) wrote :

Originator: NO

+1 (maybe "Export image"?)

Revision history for this message
Tjvigil66 (tjvigil66) wrote :

Originator: NO

Even better yet, simply "Export to PNG"

Revision history for this message
Horkana-users (horkana-users) wrote :

Originator: NO

"Export PNG" describes what Inkscape currently has but other formats will
be supported sooner or later, and although I like the "Export Image"
suggestion it might be rejected for being too vague.

A much bigger and more difficult alternative would be to reconsider how
bitmap/raster export is seperate from Save a Copy, and include formats like
PNG there too. some programs do it this way, some dont.

if you are a programmer you might increase the chances of progress on this
issue by including a patch to make the change you suggest. even if you
aren't a programmer if you are interested to learn a little then ask on the
Inkscape IRC channel a developer might be willing to help explain the
basics you need to make a patch.

Revision history for this message
towsonu2003 (towsonu2003) wrote :

Originator: NO

sorry, I don't know how to program... at all. And after your comment, this
isn't just changing one instance of a few words (see below)

From a user's point of view, make a menu like the following and it will be
flexible for you:
File > Export... > to PNG

So whenever you provide support for other formats, you can just add:
File > Export... > to PNG
File > Export... > to JPG
File > Export... > to ODT
File > Export... > to PDF

etc etc
thanks

Revision history for this message
Bug Importer (bug-importer) wrote :

"Export Bitmap" seems perfectly fine to me.

Revision history for this message
Bug Importer (bug-importer) wrote :

As Horkana pointed out, it makes much more sense to have an "Export..."
feature with the possibility of various export types. PDF is not a bitmap
format, so "Export Bitmap" wouldn't work.

nightrow (jb-benoit)
Changed in inkscape:
importance: Medium → Wishlist
status: New → Confirmed
tags: added: ui
Revision history for this message
Brynn (brynn4inks-deactivatedaccount) wrote :

Hello,
I just wanted to add a comment. I participate regularly at InkscapeForum.com, and can't tell you how many new users want to convert their SVG to PNG, and use that Cairo PNG. Even when I was 1st learning myself, I had no clue that "bitmap" meant "PNG". I thought it meant BMP.

So whatever is decided, I want to ask if it could be relatively obvious for new users.

Thanks for listening.
Brynn

Revision history for this message
John Smith (john-smithi) wrote :

For now have renamed to "Export PNG Image" since it seems the most accurate description of the current situation. When more export image formats are supported in the future, can reconsider then.

Committed to trunk r11623.

Changed in inkscape:
assignee: nobody → John Smith (john-smithi)
status: Confirmed → Fix Committed
su_v (suv-lp)
Changed in inkscape:
milestone: none → 0.49
Changed in inkscape:
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  
Everyone can see this information.

Duplicates of this bug

Other bug subscribers