Inkscape: A Vector Drawing Tool

Blur doesn't count when sizing page to fit drawing

Reported by Bug Importer on 2007-02-11
28
Affects Status Importance Assigned to Milestone
Inkscape
High
Unassigned

Bug Description

When you blur an object and then set the document properties to fit the
page to the drawing, part of the blur goes outside the page boarders.

Molumen (molumen) wrote :

Originator: NO

Yes, this is quite annoying, as this behaviour also occurs when exporting
selected blurred objects: the blur is cutted at the edge of the object.
Shouldn't be the bounding box recalculated for blurred objects?

Bryce Harrington (bryce) wrote :

Originator: NO

molumen, could you also attach an example document that shows the problem?

pbhj (pbhj) wrote :

Originator: NO

I don't know for sure, but I expect it's mathematically impossible to
bound it.

Gaussian blur appears to be an asymptotically decreasing pixel density and
so is bounded at infinity, ie the bounding box would be infinitely large.

From wikipedia (http://en.wikipedia.org/wiki/Gaussian_blur)

"In theory, the distribution at every point on the image will be non-zero,
meaning that the entire image would need to be included in the calculations
for each pixel. In practice, when computing a discrete approximation of the
Gaussian function, pixels outside of approximately 3σ are small enough to
be considered effectively zero."

It's probably better to describe the effect that you wish to see instead?

For blurred objects you could create an invisible object spanning the area
you wish to export and export that instead - not ideal I guess; perhaps an
option in the export dialog is needed for "include gaussian blur to a
distance of n standard deviations".

Molumen (molumen) wrote :

Originator: NO

Bryce, I cannot upload stuff here since I'm not the starter of the thread,
so pease download the files from here:
www.lumenstudio.net/if/blur_outside_of_page.tar.gz

The SVG features a blue blurred circle. I used the "fit page to selection"
function to resize the page at the object's size. When exporting the page
area, the blur is cutted (see png file from the .tar.gz archive). The same
cut of the blurred area occurs when exporting a selected object.

A quick workaround is to create an invisible object that is bigger than
the object's blur area, but it is not very productive...
Would be great to have that fixed somehow...

Bryce Harrington (bryce) wrote :

Originator: NO

Thanks Molumen, I've attached the file.

Also, since you've been so helpful with Inkscape bugs, I've granted you
tech & admin permissions in the Inkscape tracker. This will give you more
capabilities to assist with bugs, such as attaching files, prioritizing,
and updating status.

Bryce
File Added: blur_outside_of_page.tar.gz

Molumen (molumen) wrote :

Originator: NO

Thanks Bryce!

Prokoudine (prokoudine) wrote :

Originator: NO

Confirmed on SVN revision 16423

Changed in inkscape:
importance: Medium → High
status: New → Confirmed
Caleb Reach (jtxx000-gmail) wrote :
Changed in inkscape:
status: Confirmed → Fix Committed
bbyak (buliabyak) wrote :

just checked and it works as expected in rev 18034, without the patch, so closing

Changed in inkscape:
status: Fix Committed → Fix Released
Caleb Reach (jtxx000-gmail) wrote :

Fit to page doesn't seem to work in latest revision if nothing is selected. Here's a (slightly hacky) patch.

Changed in inkscape:
status: Fix Released → Fix Committed
bbyak (buliabyak) wrote :
Changed in inkscape:
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers