Prefs setting to disable bitmap oversampling has no effect

Bug #168346 reported by Bug Importer on 2007-02-11
12
This bug affects 1 person
Affects Status Importance Assigned to Milestone
Inkscape
Medium
Tom Davidson

Bug Description

0.45 can't set or disable bitmap images oversampling.

Amphi-users (amphi-users) wrote :

Originator: NO

Since there is no oversampling... what do you mean?

The filtering of embedded images? The antialiasing? Something else?

Polybe (polybe) wrote :

Originator: NO

In Inkscape Preferences(Shift+Ctrl+P)>Miscellaneous, you can choose the
oversampling level (size of the antialiasing filter) for bitmap images :
None, 2*2...16*16.
But a filter is applied even if you check "None" so it makes bitmap images
a little blurry after rendering.
In 0.38, this feature still works fine

Horkana-users (horkana-users) wrote :

Originator: NO

Please try to avoid filing anonymous requests. Instead please get an
account and login so we can be confident you receive any feedback we
provide or are able to ask for follow up information if necessary.

You have really got to provide more detail than this and not assume
everyone knows exactly what you mean, otherwise you make it extremely
difficult for anyone but a few people to help make progress on your bug
report and those are the very people you want developing not spending time
in the bug tracker.

Is this a regression or a feature request?

http://www.arcknowledge.com/gmane.comp.graphics.inkscape.user/2005-03/msg00097.html
this link doesn't help much but I'm starting to think this relates to the
blur functionality and that this is very much a feature request not a bug.

Polybe (polybe) wrote :

Originator: NO

Don't cry anymore, i got an account... yeah!

I can't explain better than i do in my previous comment.
If i knew which line were wrong in source code, i would say it to you,
sure. :-)

This is a regression since it works in 0.38 version.
(but an old regression, not related to new 0.45 features, in my opinion)
This is a bug since the interface for oversampling settings is still in
Inkscape (Inkscape Preferences(Shift+Ctrl+P)>Miscellaneous) but does not
work.

Polybe (polybe) wrote :

Originator: NO

In inkscape-preferences.cpp, oversampling dialog initialization:

int const num_items = 5;
    Glib::ustring labels[num_items] = {_("None"), _("2x2"), _("4x4"),
_("8x8"), _("16x16")};
    int values[num_items] = {0, 1, 2, 3, 4};
    _misc_overs_bitmap.set_size_request(_sb_width);
    _misc_overs_bitmap.init("options.bitmapoversample", "value", labels,
values, num_items, 1);
    _page_misc.add_line( false, _("Oversample bitmaps:"),
_misc_overs_bitmap, "", "", false);

In nr-arena-image.cpp, in nr_arena_image_render function :

nr_arena_image_x_sample = prefs_get_int_attribute
("options.bitmapoversample", "value", 1);

Does nr_arena_image_x_sample get the right value in the line above? Since
the oversampling
code itself in functions like
nr_R8G8B8A8_P_R8G8B8A8_P_R8G8B8A8_N_TRANSFORM (nr-compose-transform.cpp)
seems to me to be unchanged since 0.38 version.

nightrow (jb-benoit) on 2007-12-16
Changed in inkscape:
status: New → Confirmed
Tom Davidson (tjd-mit) on 2008-01-12
Changed in inkscape:
importance: Low → Medium
Tom Davidson (tjd-mit) wrote :

Marking bug 180612 as a duplicate. It would be great to also update the answer to question 21694 when this gets resolved.

Note the setting also has no effect on the 'Make a bitmap copy' command.

Can I suggest that this pref also doesn't belong in the 'misc' category, but perhaps in the Import/Export tab. Even better, let the user set it in the Export bitmap dialog along with resolution, etc.

Tom Davidson (tjd-mit) wrote :

Bug 170392 is an RFE with requests for additional antialiasing controls.

Tom Davidson (tjd-mit) on 2008-02-07
Changed in inkscape:
assignee: nobody → tjd-mit
Tom Davidson (tjd-mit) wrote :

Polybe you were right that the value was not getting properly set: the problem was that there was no entry in src/preferences-skeleton.h for the option. Patch attached (my first against Inkscape!)

Before applying this patch, the default value (2x2) was always used.

I'm also attaching a couple exported PNGs with 'none', and with '16x16' oversampling. Note that changing the setting doesn't trigger an immediate redraw of the canvas, so you may have to hide and re-show the canvas to see the difference.

Tom Davidson (tjd-mit) wrote :
Tom Davidson (tjd-mit) wrote :
Bryce Harrington (bryce) wrote :

Applied and committed.

Changed in inkscape:
status: Confirmed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers

Patches