Inkscape: A Vector Drawing Tool

References to non-installed fonts break text toolbar (can't change font; font size display errors)

Reported by Marcin Floryan on 2007-02-07
126
This bug affects 3 people
Affects Status Importance Assigned to Milestone
Inkscape
Critical
Unassigned
Nominated for 0.46.x by Luca Bruno
inkscape (Fedora)
Invalid
Unknown

Bug Description

Using a text tool - when there are two text objects and size is specified
on one, the font size stays with the previously selected value (the drop
down value) while the actual font size may be different on the new object.
In short - font size could reflect the size of currently selected text or
be cleared when flipping back and forth between text objects.

Bryce Harrington (bryce) wrote :

Originator: NO

(I cannot reproduce this on Linux, can anyone else reproduce it on
windows?)

Which version of Inkscape are you using?

Marcin Floryan (mfloryan) wrote :

Originator: YES

I am using 0.45 for Windows (XP)

Mercury (mercury13) wrote :

Confirmed. 0.45.1-1, WinXP.

Way to reproduce.

1. Make two texts.
2. Choose text tool, click on one if the texts. Click size box, ERASE everything and enter your own size.
3. Click in turn on the texts.

It seems to me, it misbehaves when in "svg:text.style" property "font-family" is missing.

Mercury (mercury13) on 2007-12-18
Changed in inkscape:
status: New → Confirmed
bbyak (buliabyak) wrote :

i'm not sure what exactly was this bug, but it works for me as of rev 17194, most likely fixed with bug 168397

Changed in inkscape:
assignee: nobody → buliabyak
status: Confirmed → Fix Released
Marcin Floryan (mfloryan) wrote :

Just verified with 0.45+0.46pre0-1 win32 available for download and the anticipated behaviour still does not seem to be there.

Steps tested:
1. Open new blank document
2. Create a text (font size 12) - text1
3. Click to create new text, change font size to 18, enter text - text2

So now there are two texts one in size 12 one in size 18

4. Select text1 - select text tool (F8) - the text size in the drop-down is still showing 18 though if you try and type more the size of 12 will actually be maintained.

In short - the text size drop-down will always show the most recently selected test-size and not (as I believe would be sensible) the size of the currently selected text (if there is one naturally).

Marcin Floryan (mfloryan) wrote :

Expected behaviour still not im place

Changed in inkscape:
status: Fix Released → In Progress
Tom Davidson (tjd-mit) wrote :

When I follow those steps I don't see this bug anymore (SVN rev 17195, Linux)

Bulia just commited a bunch changes to the font drop-down menu code today, what SVN revision are you running? Or, if you don't know the SVN rev, then can you report where you downloaded Inkscape from, and on what day?

Tom Davidson (tjd-mit) wrote :

Setting back to fix-released until Marcin has a chance to report back about latest SVN version...

Changed in inkscape:
status: In Progress → Fix Released
Marcin Floryan (mfloryan) wrote :

I have just downloaded Inkscape0801272207.7z - which is the latest available Win32 binary (sorry, I am currently not able to build on my windows machine from SVN). The problem still seems to exists. Please have a look at the screenshot attached. The text size should be 72 and not 8 but the small text was the one I have created as last.
I think, however, this seems to be a Windows issue as I recall I tried it on my linux machine and it worked OK (Can confirm this afternoon).

Tom Davidson (tjd-mit) wrote :

Hmm--I just reinstalled 0.45.1, which doesn't display this bug. I guess that means it's likely Windows-specific. I'll disappear now... <poof>

Changed in inkscape:
status: Fix Released → In Progress

I have downloaded source from SVN and built it on my Windows machine and I think I know why this problem occurs.

In windows the default font is Sans - but on my machine, there is no such font. Therefore a comment on lines 358 - 361 in
static void sp_font_selector_emit_set
of src/widgets/font-selector.cpp
seems to indicate the problem we see.

If I change the font (Shitf+Ctrl+T) and its size then the Text toolbar (F8) shows both the font and size correctly.

This brings another problem - I am unable to change the font (family, not size) of a default text using the toolbar (F8).

Therefore I think the really is a manifestation of another bug.

hash (hash-g) wrote :

Can't reproduce on xp sp2 Inkscape0801301416.7z 30-Jan-2008, looks fixed to me.

Tom Davidson (tjd-mit) wrote :

Marcin, I think you have found the problem: I can duplicate this on Fedora in most recent SVN by editing my preferences.xml file. I replaced 'Bitstream Vera Sans' with 'NotARealFontName'...

I can also trigger it by opening any file containing a font that is not installed (see attachment, which contains text in the font named 'NotARealFontName')

I also get many errors to the console that look like this:
** (inkscape:11288): WARNING **: Family name NotARealFontName does not have an entry in the font lister.

I also confirm that I can't change the font using the picker in the toolbar in the SVG I just attached.

There is a workaround: you can change the font if you use the 'Text and Font' dialog (Ctrl-Shift-T), rather than the text toolbar...

I have encountered this same problem in the most recent Windows binary (0.45+0.46pre0). After manually changing the default font in preferences.xml (since "Bitstream Vera Sans" was actually "Bitstream Vera Sans Mono" on my system) I was then able to change fonts through the toolbar only after first applying a font change through the text properties dialog. This caused me to look into the XML Editor to compare and found that within the text element's style attribute the following was missing by default: -inkscape-font-specification. After updating the element through the text dialog this tag was populated. I assume then that inkscape is missing a default directive to change the font if this tag is not present in the style directive (manually removing the tag from a complete style attribute also failed to allow for toolbar font changes and seems to confirm this theory)...

Tom Davidson (tjd-mit) wrote :

High importance, since that's what Bryce gave to a dupe that I just merged in.

Changed in inkscape:
importance: Medium → High
Lubomir Rintel (lkundrak) wrote :

So the Font picker obviously doesn't works as expected, below are my observations. As some of them were not mentioned maybe they qualify for a separate bug. So;

1.) Reproducible on Fedora running 0.46pre1 (only text tool relevant patch is from bug #190722, I also used patch from svn instead of ours)
2.) In some cases drop down font selection menu doesn't disappear when font is selected, user has to press Enter.
3.) In the cases described above font change does not apply
4.) Activating the tool with F8 makes a warning /!\ icon appear rolling over which pops up a tooltip saying that the font is not installed, even if it is
5.) No error messages on console

Screencast demonstrating some of these is https://bugzilla.redhat.com/attachment.cgi?id=294955

Changed in inkscape:
status: Unknown → In Progress
bbyak (buliabyak) wrote :

setting font when the default is not installed should work as of rev 17351, please test

the rest of problems with the font drop-down are not fixed unfortunately, but they are tracked by other bugs I think

Changed in inkscape:
status: In Progress → Fix Released
Tom Davidson (tjd-mit) wrote :

In particular, Lubomir's issue #2 (drop down menu doesn't disappear when font is selected) is tracked at bug 168161

Changed in inkscape:
status: In Progress → Invalid
nightingale2k1 (adwin-wijaya) wrote :

.46 windows Font drop down doesnt work at all for choosing fonts.

Marcin Floryan (mfloryan) wrote :

It does work after the font is changed from a default on to an existing one (via Ctrl+T).

Marcin Floryan (mfloryan) wrote :

Just tested this today on Win and Linux with most recent SVN version where default font is set to one, that does not exist in the system (Sans in Windows and Bitstream Vera Sans under Linux). The behaviour is precisely as described in the initial bug report.

Changed in inkscape:
assignee: buliabyak → nobody
status: Fix Released → Confirmed
Marcin Floryan (mfloryan) wrote :

Sorry, one small update - in Linux, once the font has been changed via Ctrl+T it is properly shown in the dropdown but the list still can't be used for changing the font. If the text object is selected the dropdown allows other fonts to be selected (though selected a different item does not have any effects - ie. the font does not change) but when the text itself is selected (highlighted) then no other font can be selected in the list.

Mercury (mercury13) wrote :

0.46 Windows XP SP2.

What's fixed...
1. SVG isn't littered now.

What's added...
1. Font drop-down doesn't work at all.
2. Size drop-down is corrupted and doesn't reflect real text size.

Setting importance to Critical.

Changed in inkscape:
importance: High → Critical
Bheku (bheku7) wrote :

Confirming above. 0.46 Windows XP SP2. Font drop down not working. Can resize, but I don't have enough technical/design experience to confirm if size is correct.

Stuck on Georigia font.

JudithK (jakmiami) wrote :

The font picker also does not work with V0.46 running on Windows 2000 Pro. However, a font size change made from the text control bar does remain in effect.

The only way I can change fonts is to use the Text and Font dialog box.

Dominic (don-gee) wrote :

Confirmed for 0.46 WinXP SP3.

Bug confirmed in 0.46 on Vista HP.
Ctrl-Shift-T works OK.
Note also, that I've tried to type the font name directly in the toolbar, and when I pressed Enter, a warning icon appeared on the toolbar with a message (in Polish; sorry - I don't know where to look for the translation scripts - probably you know better) stating: "Ta czcionka nie jest aktualnie zainstalowana w systemie. Inkscape będzie używał zamiast niej czcionkę domyślną." - if translated to English, this message means: "This font is not currently installed on your system. Inkscape will use the default font instead."

mete (meteislam) wrote :

I have what he has and I can't change the type of font on any file either, I can only change the size
I have tried Uninstalling Inkscape, deleting it from Program Files as well as Application Data, I tried installing in a new XP admin, no matter what I do I cant change the font type

mete (meteislam) wrote :

I forgot to mention I have Win XP SP3 as well

mete (meteislam) wrote :

Inkscape 0.46 (sorry again)

lupus (kristof-vansant) wrote :

Are there older versions which work? Otherwise inkscape is kind of useless for me at the moment :s

mahfiaz (mahfiaz) wrote :

lupus, see this comment of Marcin Floryan, written on 2008-04-09:
"It does work after the font is changed from a default on to an existing one (via Ctrl+T)."

Does this help you?

Charles Plessy (plessy) wrote :

Dear Inkscape developpers,

We are preparing to release Debian with Inkscape 0.46, and consider using a patch to solve the problem. You can consult the patch on our bug tracker:

http://bugs.debian.org/cgi-bin/bugreport.cgi?bug=496784#46

What is your opinion about the patch ?

Have a nice day,

--
Charles Plessy
Tsurumi, Kanagawa, Japan

Luca Bruno (lucab) on 2008-11-01
Changed in inkscape:
milestone: none → 0.46.1
bbyak (buliabyak) wrote :

fixed in 21527, now font is changeable even if the old one does not exist

re patch for debian: thanks but your patch fixes a wrong problem - it is not inkscape's business to decide which font to use when bitstream vera is not available, it is pango who substitutes the virtual "sans" for it, and that choice is good enough; the only problem is that inkscape then fails to change from that virtual font to any real one, and i just fixed that.

Changed in inkscape:
status: Confirmed → Fix Released
Charles Plessy (plessy) wrote :

Many thanks for the notice! I forwarded it the the Debian maintainer of Inkscape.

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.