clipping cloned objects (clones) has problems

Bug #168013 reported by Bugbear6502 on 2006-10-06
8
This bug affects 1 person
Affects Status Importance Assigned to Milestone
Inkscape
Medium
Mc

Bug Description

I created a simple rectangle with a gradient

I cloned this rectangle, and created an oval object
inside it.

I set the oval as a clip on the cloned rectangle.

Moving (translating) the original (master)
rectangle moves the clip path (the oval) relative
to the cloned rectangle.

Desired behaviour; Moving the original should not
alter the clipped composite at all.

(Motivation: I was attemptiong to have
a "master" gradient, with
multiple clones, so I could edit the colours
of all the clipped gradients in one go)

   BugBear

Bugbear6502 (bugbear6502) wrote :
Bugbear6502 (bugbear6502) wrote :

I'm guessing this may be related to 1520625

Bug Importer (bug-importer) wrote :

It happens in 0.45 too. Possible workaround is creating clone of a clone,
and only clipping this second clone instead. Moving the original will now
have no effect on the clipped second clone, however moving the first clone
now will cause an identical problem.

Ryan Lerch (ryanlerch) on 2008-01-15
Changed in inkscape:
importance: Undecided → Medium
status: New → Confirmed
Tom Davidson (tjd-mit) wrote :

Weird!--confirmed in SVN 17039 (Jan 13,2008)

jazzynico (jazzynico) wrote :

Reproduced in revision 22560 on Ubuntu 9.10.

tags: added: clipping clones transformations
su_v (suv-lp) wrote :

Reproduced with Inkscape 0.48+devel r9994 on OS X 10.5.8

The clip-path is moved in the opposite direction of the translation applied to the original (overcompensation of a parent transform?). Does not happen if the to-be-clipped clone is wrapped in a group first (as can be done automatically in 0.48 per preference setting).

Mc (mc...) wrote :

fixed in rev 14129

Changed in inkscape:
status: Confirmed → Fix Committed
su_v (suv-lp) on 2015-05-08
Changed in inkscape:
milestone: none → 0.92
assignee: nobody → Mc (mc...)
su_v (suv-lp) on 2015-09-30
tags: added: backport-proposed
su_v (suv-lp) wrote :

Fix backported to 0.91.x in rev 13830.

Changed in inkscape:
milestone: 0.92 → 0.91.1
tags: removed: backport-proposed

Don't know if this is solved with the committed fix, but also removing the original of a clipped clone (or unlinking it) undoes the clipping.
To reproduce:
- make eg. a blue rectangle
- clone the blue rectangle and displace it (so that original and clone do not overlap)
- make eg. a red circle on top of the clone
- select red circle + clone -> clip
- delete the original blue rectangle (or unlink the clone)
- unwanted effect: the red circle disappears and clipping is undone

(forgot to mention: my previous comment is in Inkscape 0.91 r13725 in Ubuntu 16.04)

jazzynico (jazzynico) on 2017-01-28
Changed in inkscape:
milestone: 0.91.1 → 0.92
status: Fix Committed → Fix Released
Antonio Ospite (ospite) wrote :

Hi,

the bug is fixed in 0.92.2 for the test case submitted by the OP, but the problem is still there if the clipped clone has any transformation applied to it.

See the attached test file "clipped-clone-demo.svg".

Can this report be re-opened, or do I need to open a new one?

Thanks,
   Antonio

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers