The tooltip text is not visible

Bug #1677433 reported by ImorePH@gmail.com
20
This bug affects 3 people
Affects Status Importance Assigned to Milestone
Inkscape
New
Undecided
Unassigned

Bug Description

Im using linux mint 18.1 with KDE Plasma 5.8 DE.

When opening the inkscape from menu launcher, it gives visible tooltip text.
But when opening inkscape from saved svg file (opening directly from the file), the tooltip text is not visible.

I attach the screnshoot for invisible tooltip text.

Tags: ui
Revision history for this message
ImorePH@gmail.com (imoreph) wrote :
jazzynico (jazzynico)
tags: added: ui
Revision history for this message
V字龍(Vdragon) (vdragon) wrote :

Reproduced on KDE neon 5.10, I wonder if this is a KDE-specific bug?

I've changed the GTK theme to Breeze-Dark but doesn't see any improvements...
?field.comment=Reproduced on KDE neon 5.10, I wonder if this is a KDE-specific bug?

I've changed the GTK theme to Breeze-Dark but doesn't see any improvements...

Revision history for this message
V字龍(Vdragon) (vdragon) wrote :

I noticed that after I switch GTK2 theme to non-Breeze-* the issue is no longer produced.

Maybe it's a issue in the Breeze theme?

Revision history for this message
V字龍(Vdragon) (vdragon) wrote :
Revision history for this message
V字龍(Vdragon) (vdragon) wrote :

I investigated the Breeze theme and noticed that it has the following `gtkrc` settings:

gtk-color-scheme = "tooltip_fg_color:#eff0f1"
gtk-color-scheme = "tooltip_bg_color:#31363b"

and after using Gpick to pickup the actual color used in Inkscape, I noticed that while Breeze theme demanded #31363b tooltip background color(which is pretty dark), the actual color used in Inkscape is #efece7, which is nearly the same with the tooltip foreground color, causes the issue.

I suspect that somewhere in Inkscape has overridden the tooltip background color with #efece7.

Revision history for this message
Hachmann (marenhachmann) wrote :
Revision history for this message
V字龍(Vdragon) (vdragon) wrote :

@Hachmann
Thanks for the workaround/fix, shall I report to KDE upstream about this issue, or it is already reported?

Revision history for this message
Bicyclops (bugs-8) wrote :

See https://bugs.launchpad.net/inkscape/+bug/1781887

It's not just tooltips which differ.

Revision history for this message
Bicyclops (bugs-8) wrote :

*It's not just colors which differ.

To post a comment you must log in.
This report contains Public information  
Everyone can see this information.

Duplicates of this bug

Other bug subscribers