Crash on imported image update (during Gimp save)

Bug #167390 reported by Jpdietrich on 2006-03-27
24
This bug affects 2 people
Affects Status Importance Assigned to Milestone
Inkscape
Medium
Krzysztof Kosinski

Bug Description

Step 1: Insert a fairly large bitmap image into
Inkscape. I used a 6.6Mb png.
Step 2: Open that image in an image editor (Gimp), make
some changes, and then save.
Step 3: During the save in Gimp, go back to Inkscape
and update the graphic link by nudging the graphic with
an arrow key.

Current behavior: Inkscape loads the partial image
(however much has been saved) and then crashes.

Proposed correct behavior: Inkscape loads the partial
image and pops up with a dialog box "Incomplete image"
or "corrupted image data" or possibly just turns the
image to the red X broken link symbol.

I'm running Linux kernel 2.6.12 with Inkscape version
0.42. I actually discovered the bug running on OSX
10.4.5 with Inkscape version 0.43.

Rwst (rwst) wrote :

thanks for the report.

Bryce Harrington (bryce) wrote :

Upping to 9 since this is a crash bug.

Jflemaire (jflemaire) wrote :

I can't reproduce this under Linux with Inkscape SVN. I
tried with a 55 MB png and an 8 MB tiff. The image is not
updated at all when I move it, but Inkscape doesn't crash.

Jon A. Cruz (jon-joncruz) wrote :

From what I know of the code involved, Inkscape does no further file IO
once an
image is first imported (in fact, there are several RFE's and/or bugs
asking for
this to be changed).

However, with larger images being involved and with switching applications

being involved, it's very possible there's some problem with memory
allocation
or swapping.

Bryce Harrington (bryce) wrote :

Originator: NO

Since it can't be reproduced, and since Inkscape's image loading likely
isn't involved in the crash, I'm closing this. If someone else can confirm
the same behavior in a manner that is recreatable by a developer, please
reopen.

Bertrand Petit (bp-lp) wrote :

This bug is still present in 0.47pre4 in FreeBSD with libpng v1.2.38.

Here is the terminal output:

** Message: error loading pixbuf at close
libpng error: IDAT: CRC error

Emergency save activated!
[...]

Unfortunately I do not have a core dump.

su_v (suv-lp) on 2009-11-07
tags: added: bitmap importing performance
removed: transformations
Changed in inkscape:
status: Invalid → New
importance: Critical → Medium
jazzynico (jazzynico) wrote :

Confirmed on Ubuntu 9.10, Inkscape r8863.

Changed in inkscape:
status: New → Confirmed
jazzynico (jazzynico) wrote :

gdb trace:

(file-png:19713): GLib-WARNING **: g_set_prgname() called multiple times
libpng error: IDAT: CRC error

Program received signal SIGABRT, Aborted.
0x00542422 in __kernel_vsyscall ()
(gdb) bt
#0 0x00542422 in __kernel_vsyscall ()
#1 0x074b04d1 in raise () from /lib/tls/i686/cmov/libc.so.6
#2 0x074b3932 in abort () from /lib/tls/i686/cmov/libc.so.6
#3 0x00cb8e65 in png_create_read_struct_2 () from /usr/lib/libpng12.so.0
#4 0x00001b67 in ?? ()
Backtrace stopped: previous frame inner to this frame (corrupt stack?)

su_v (suv-lp) on 2010-06-24
tags: added: crash
removed: performance
jazzynico (jazzynico) wrote :

Also reproduced on Windows XP, Inkscape trunk revision 13012.

tags: removed: linux
Changed in inkscape:
status: Confirmed → Triaged
jazzynico (jazzynico) wrote :

Not reproduced anymore on Crunchbang Waldorf, Inkscape trunk revision r13119. Very likely to be fixed by r13117 (https://bazaar.launchpad.net/~inkscape.dev/inkscape/trunk/revision/13117).

Proposing to backtport the 0.48.5.

Changed in inkscape:
assignee: nobody → Krzysztof Kosinski (tweenk)
milestone: none → 0.91
status: Triaged → Fix Committed
tags: added: backport-proposed
Krzysztof Kosinski (tweenk) wrote :

Backported to stable in r10013. Inkscape no longer crashes in this case, but the image is replaced with the "Linked image not found" graphic. Right-clicking and selecting "image properties" from the menu shows the image again.

Changed in inkscape:
milestone: 0.91 → 0.48.5
tags: removed: backport-proposed
Changed in inkscape:
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers

Related blueprints