Inkscape: A Vector Drawing Tool

align text objects relative to last selected doesn't work

Reported by Keichwa on 2006-01-12
114
This bug affects 15 people
Affects Status Importance Assigned to Milestone
Inkscape
Medium
Unassigned

Bug Description

[I reported the bug at first as
https://bugzilla.novell.com/show_bug.cgi?id=137809 as a
SUSE Linux 10.0 issue.]

 The issue could also be reproduced with inkscape
0.43-3 from
ftp.suse.com/pub/suse/i386/supplementary/GNOME/update_for_10.0/applications
/

I cannot align text elements according to "First
selected" or "Last selected".
I guess inkscape always aligns according to /First
created/ or something like
that.

- Create three or more text elements in a horizontal
row but un-aligned.
- From "Object" open "Align and Distribute".
- Set "Relative to:" to "Last selected".
- Mark all text objects (hold down Shift while marking
the object)
- Click the under-dotted "A" and text objects are aligned.

In case inkscape actually did it "Relative to:" "Last
selected" (as specified),
do a second test.

- Press undo (Ctrl-Z).
- Set "Relative to:" to "First selected".
- Mark all text objects in the same sequence.
- Click the under-dotted "A" and text objects are
aligned, but not according to
"First selected" and that's the bug.

Rwst (rwst) wrote :

Confirmed on OpenSuSE 10.1

Origien (origien) wrote :

Confirmed on Windows (originally posted as bug 1335385)

Bug Importer (bug-importer) wrote :

Confirmed on Inkscape 0.44, built Oct 9 2006 (Ubuntu)

aligning text elements vertical or horizontal according to
its base line does not work correctly with the Options "move
relatively to: first selected / last selected / biggest
object /smallest object"
(I only have the german version, there it is the button
"Grundlinie der Textelemente horizontal ausrichten"
and "Grundlinie der Textelemente vertikal ausrichten"
with the Options "Zuerst gewählt" / "Zuletzt gewählt" /
"Größtes Objekt" / "Kleinstes Objekt".)

It does not align according to first created or something
like that,
it always aligns according to the most left-handed object
(using vertical align),
and to the object which is nearest to the bottom of the site
(using horizontal align).

Ryan Lerch (ryanlerch) on 2008-01-14
Changed in inkscape:
status: New → Confirmed
Tom Davidson (tjd-mit) wrote :

Seems to be fixed in 0.45+devel (SVN rev 17039)... Since this last saw activity in 0.44, I'm just gonna mark it fix released... Tried both vertical and horizontal alignment of 3 text objects. Both first and last selected work as expected.

Changed in inkscape:
status: Confirmed → Fix Released
~suv (suv-lp) wrote :

This bug is still present in Inkscape 0.46+devel r22516

re-opening and setting related newer reports as duplicate of this one.

Changed in inkscape:
status: Fix Released → Confirmed
tags: added: text transformations
removed: other
~suv (suv-lp) wrote :

reproduced with Inkscape 0.47+devel r9036 on OS X 10.5.8.

Raising importance to 'Medium', based on the number of duplicates and because IMHO it is a very basic option of aligning (text) objects that fails.

Changed in inkscape:
importance: Low → Medium
Christopher Oezbek (c-oezbek) wrote :

I just wanted to mention to whoever is going to implement this, that there is a series of bugs with the alignment dialogs to be solved probably all in one go:

#168788 - Using a single object in a group to move the whole group during alignment
#172001 - Remove overlap relative to anchor
#288146 - Align/distribute Bezier node handles
#569096 - Add anchor to "distribute" commands
#569137 - Aligning objects centered is missing options

And I was looking for a bug report to center objects to text (try to center a bullet point in front of a Text object which stretches below the base line to see what I mean), but didn't find one, but this probably should be fixed as well.

~suv (suv-lp) on 2010-05-19
tags: added: aligning
removed: transformations
texnic (kotya-karapetyan) wrote :

Reproduced in Inkscape 0.48.1.

houz (houz) wrote :

Just for the record: this is still not fixed in r13185.

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers