no horizontal scroll on OS X

Bug #167191 reported by Whitehat101 on 2005-12-22
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
Inkscape
Low
Michael Wybrow

Bug Description

Shift + Scroll doesn't do anything.
(at least on OS X 10.3.9 with apple's X11.app) with the
most currnet (20051216) snapshot build (and the .43
release)

Michael Wybrow (mjwybrow) wrote :

I have had a look at this. There are no scroll events being
generated by GTK when the shift button is held down. This
is either a bug in GTK or possibly OSX is stealing these
events when shift is held. I'll try to find out if this is
a gtk problem.

Michael Wybrow (mjwybrow) wrote :

Turns out this *is* a bug in X11. Not much we can do about
it at our end, sorry!

See this page:
http://lists.apple.com/archives/x11-users/2004/May/msg00029.html

Wolf (drechsel) wrote :

I've got the same problem in aqua… (inkscape 0.47 AQUA, devel-r9101, OS 10.4.11)

su_v (suv-lp) on 2010-02-26
tags: added: ui
su_v (suv-lp) wrote :

reopening: current versions of X11/Xquartz _do_ receive X events for horizontal scrolling with <Shift>+mouse wheel (verified with xev).

Other widgets inside Inkscape itself know about <Shift>+mouse wheel and scroll horizontally as expected (examples are the palette window just below the canvas, or the pane on the right side in the preferences dialog.

Interestingly using the trackpad to scroll horizontally as well as tilting the mouse wheel left/right (if available) does scroll the main canvas horizontally.

-> Possibly some (internally hard-coded) shortcut filtering grabs the 'Shift' event for the main window and in effect disables that X11 and/or the osx system receive the key press state when using the mouse wheel to scroll the canvas horizontally.

tested with on OS X 10.5.8 with XQuartz 2.4.0:
- Inkscape 0.47 r22583
- Inkscape 0.47+devel r9506 (local build)
- gtk-demo, installed gtk2 @2.20.1 (x11) using MacPorts

Changed in inkscape:
importance: Undecided → Low
status: Invalid → Confirmed
su_v (suv-lp) wrote :

xev output for mouse wheel (tilt left/right, Shift+up/down) on Mac OS X 10.5.8 with Xquartz 2.4.0

su_v (suv-lp) wrote :

Forgot to explicitly mention the reason for reopening this bug:
Issue as originally reported ("Shift + Scroll doesn't do anything.") reproduced with Inkscape 0.47 and 0.47+devel r9506 on OS X 10.5.8 with X11/Xquartz 2.4.0: horizontal scrolling of the _canvas_ using <Shift>+mouse scroll wheel fails. Other widgets in Inkscape do support horizontal scrolling as expected (palette, preferences).

Workarounds if supported by the hardware:
- tilt the mouse wheel left/right
- scroll with trackpad gestures (two-finger-drag horizontally)

Alternatively use conventional scrolling by either dragging the scrollbar slider with the mouse or scrolling the mouse wheel while hovering over the horizontal scrollbar.

Alexey (alexey-muranov) wrote :

Same problem with Inkscape 0.48.5 and XQuartz 2.7.7 on Mac OS 10.9.5.

Leo Treasure (leotreasure) wrote :

Wow this is an old bug! El Capitan here

Leszek (l-p-pryszcz) wrote :

Same here, no Shift + Scroll vertical scrolling on Ubuntu 16.04 with Inkscape 0.91 r13725.

http://stackoverflow.com/q/1175192/632242 solved the problem for Firefox, but still not working with Inkscape...

Any idea?

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers