Powerstroke LPE still hangs

Bug #1668853 reported by Parcly Taxel on 2017-03-01
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
Inkscape
Undecided
Unassigned

Bug Description

(Trisquel 7.0, Inkscape r15556)

As a follow-up to my previous report of hanging powerstrokes (https://bugs.launchpad.net/inkscape/+bug/1487424) here's another file which causes Inkscape to hang (by going into an infinite loop, because no error messages are printed) if reading it is attempted. Once again, one of the Bézier segments has a control point coincident with one of its endpoints.

The bug remains if I change the interpolator to CubicBezierSmooth; the SVG file from which I extracted this can be found at https://sta.sh/01xswiypahms (or at http://stjonal.deviantart.com/art/Everfree-background-660344136).

Alvin Penner (apenner) wrote :

attached is a proposed patch for this bug. I will leave this here until the weekend, and if there is no adverse reaction, then I will commit it (again).

This patch is an exact duplicate of what was previously committed in rev 15003 to trunk:
https://bugs.launchpad.net/inkscape/+bug/1593963
http://bazaar.launchpad.net/~inkscape.dev/inkscape/trunk/revision/15003

This was also committed to lib2geom in github as well:
https://github.com/inkscape/lib2geom/blob/master/src/2geom/sbasis-geometric.cpp

For some inexplicable reason, this patch appears to have been reverted in trunk in rev 15047.
http://bazaar.launchpad.net/~inkscape.dev/inkscape/trunk/revision/15047#src/2geom/sbasis-geometric.cpp

It looks to me as though this last revert was probably unintentional.

Alvin Penner (apenner) on 2017-03-01
Changed in inkscape:
status: New → Confirmed
su_v (suv-lp) wrote :

Alvin Penner wrote:
> For some inexplicable reason, this patch appears to have been
> reverted in trunk in rev 15047.

See also:
* Bug #1669951 “Merge in r15047 reverts some earlier commits”
  https://bugs.launchpad.net/inkscape/+bug/1669951
Based on your comment, I briefly checked other changes in r15047: there seem to be a few more (unintended) reverts contained in that merge.

Alvin Penner (apenner) wrote :

thanks, ~suv!

committed to rev 15563

Changed in inkscape:
status: Confirmed → Fix Committed
su_v (suv-lp) on 2017-03-04
Changed in inkscape:
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Bug attachments