Envelope Deformation LPE makes Inkscape fail to undo properly

Bug #1668003 reported by Parcly Taxel on 2017-02-26
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
Inkscape
Undecided
Jabiertxof

Bug Description

(Trisquel 7.0, Inkscape r15546)

1. Open the attached file
2. Move the purple rectangle twice
3. Undo twice

What happens:
The first undo operation works just fine. The second one, however, fails to execute at all. When Inkscape is executed from the command line the following appears:

(inkscape:4465): Gtk-WARNING **: Failed to set text from markup due to error parsing markup: Error on line 1: Entity did not end with a semicolon; most likely you used an ampersand character without intending to start an entity — escape ampersand as &

** (inkscape:4465): WARNING **: Incomplete undo transaction:

** (inkscape:4465): WARNING **: Event: Set attribute d to "m 15.524,16.792 6.272,3.264 1.26,-10.506 2.016,10.166 4.928,-1.36 -3.78,5.236 3.276,5.236 -4.676,-1.836 -1.12,10.778 -1.764,-10.982 -5.152,2.516 3.892,-6.018 z m -35.756,11.384 4.704,2.592 0.945,-8.343 1.512,8.073 3.696,-1.08 -2.835,4.158 2.457,4.158 -3.507,-1.458 -0.84,8.559 -1.323,-8.721 -3.864,1.998 2.919,-4.779 z m -21.152,-28 6.048,2.592 1.215,-8.343 1.944,8.073 4.752,-1.08 -3.645,4.158 3.159,4.158 -4.509,-1.458 -1.08,8.559 -1.701,-8.721 -4.968,1.998 3.753,-4.779 z m 13.344,-43.64 4.48,2.112 0.9,-6.798 1.44,6.578 3.52,-0.88 -2.7,3.388 2.34,3.388 -3.34,-1.188 -0.8,6.974 -1.26,-7.106 -3.68,1.628 2.78,-3.894 z m 39.732,4.576 5.376,2.304 1.08,-7.416 1.728,7.176 4.224,-0.96 -3.24,3.696 2.808,3.696 -4.008,-1.296 -0.96,7.608 -1.512,-7.752 -4.416,1.776 3.336,-4.248 z m -16.192,35.188 -9.3,-17.2 13.5,13.3 8.6,-13.8 -4.7,15.8 16.5,5.6 -15.9,2.6 6.1,19.3 -11.9,-20.5 -7.8,18.2 3.4,-19.7 -14.8,-2 z" on #<Element:0x0x14d6fd0>

** (inkscape:4465): WARNING **: Event: Set attribute d to "m -29.2,-21.2 22.4,9.6 4.5,-30.9 7.2,29.9 17.6,-4 -13.5,15.4 11.7,15.4 -16.7,-5.4 -4,31.7 -6.3,-32.3 -18.4,7.4 13.9,-17.7 z" on #<Element:0x0x14d6ee0>

** (inkscape:4465): WARNING **: Event: Set attribute d to "m 22.116461,18.321374 c 1.760924,1.089834 3.505035,2.175916 5.239651,3.263338 0.976495,-3.75618 1.755873,-7.543276 2.323396,-11.342944 0.43068,3.622306 0.673595,7.246057 0.737615,10.854487 1.5806,-0.551695 3.157336,-1.110755 4.729233,-1.677347 -1.407869,1.945226 -2.870806,3.87353 -4.38451,5.782937 0.650098,1.824623 1.25622,3.646206 1.819188,5.462658 -0.05676,-0.02646 -3.803748,-1.771602 -3.860503,-1.798066 -1.202846,3.819121 -2.605007,7.593714 -4.191042,11.30413 0.7197,-3.76247 1.251276,-7.581077 1.582629,-11.433942 -1.781311,0.935749 -3.575446,1.86141 -5.379954,2.776628 1.728226,-2.127592 3.394914,-4.278705 4.994552,-6.449839 -1.137989,-2.245509 -2.340747,-4.493421 -3.610255,-6.74204 z m -35.017021,12.293575 c 1.200182,0.89834 2.389409,1.790919 3.5724059,2.681544 1.0967971,-2.838816 2.0853028,-5.705022 2.9599427,-8.589495 -0.108786,2.791821 -0.3217896,5.568392 -0.6349567,8.322879 1.2304316,-0.364836 2.4594589,-0.732581 3.6865227,-1.103179 -1.2480815,1.42417 -2.5244917,2.83958 -3.8276292,4.244629 0.3120716,1.411523 0.5987501,2.816767 0.8605524,4.21509 0.059008,0.03235 -2.7678678,-1.518348 -2.7088598,-1.485995 -1.228603,2.876383 -2.567873,5.718578 -4.011943,8.516912 0.805158,-2.859042 1.502365,-5.760114 2.086245,-8.694109 -1.405236,0.662203 -2.816898,1.319905 -4.233792,1.972635 1.460939,-1.583844 2.88797,-3.182136 4.279102,-4.792441 -0.637172,-1.753325 -1.312647,-3.516217 -2.02759,-5.28847 z m -15.420929,-29.6137283 c 1.82061,0.9866423 3.633053,1.96075 5.433717,2.9219974 0.232809,-1.6040918 0.428696,-3.20833444 0.586812,-4.81114113 0.01227,-0.11946147 0.02434,-0.23893667 0.03619,-0.35842557 0.115214,-1.1950031 0.210436,-2.3885774 0.286265,-3.5805042 0.319944,1.2042098 0.62105,2.4092831 0.90257,3.6148984 0.02764,0.120605 0.05507,0.24119137 0.08229,0.36175772 0.352738,1.52154756 0.673092,3.04283428 0.961591,4.56314588 1.435169,-0.3451382 2.867732,-0.6951974 4.296929,-1.0503721 -1.099584,1.4376399 -2.232862,2.8743353 -3.397553,4.3081649 0.884595,1.475923 1.741046,2.9471245 2.570124,4.41432 -1.317068,-0.529548 -2.637156,-1.064026 -3.959399,-1.6035133 -0.544135,2.9888353 -1.214032,5.9719423 -2.004315,8.9392643 -0.04185,-3.04133 -0.206605,-6.099821 -0.498785,-9.1685906 -1.547959,0.6616606 -3.104516,1.3192166 -4.667386,1.9722416 1.287017,-1.6394434 2.535015,-3.2830764 3.741244,-4.9278289 -1.414146,-1.8534035 -2.869954,-3.7171085 -4.370298,-5.5954144 z m 3.035448,-44.4969607 c 1.559354,0.740493 3.112825,1.472867 4.662658,2.198233 -0.562922,-2.246257 -1.177111,-4.474765 -1.837419,-6.683506 1.299739,2.150209 2.56204,4.31725 3.781572,6.498722 0.905964,-0.277584 1.807859,-0.559689 2.705655,-0.84639 -0.3479,1.114823 -0.712731,2.231661 -1.094845,3.350547 1.072584,1.13369 2.134937,2.269008 3.185895,3.405265 -1.097363,-0.400615 -2.196242,-0.80538 -3.297085,-1.214514 0.54891,2.328137 1.040211,4.673172 1.468328,7.032897 -1.042934,-2.411972 -2.146808,-4.810482 -3.304988,-7.192694 -0.886847,0.524898 -1.780611,1.045703 -2.681343,1.562684 0.396505,-1.285123 0.770944,-2.567009 1.123895,-3.845738 -1.554519,-1.420848 -3.126469,-2.843535 -4.712323,-4.265506 z m 35.601849,3.722371 c 1.806153,0.641546 3.608222,1.273871 5.409249,1.898594 -0.670802,-2.512162 -1.413784,-5.00091 -2.221508,-7.462798 1.539504,2.30256 3.032337,4.630716 4.470495,6.982221 1.045221,-0.446365 2.083887,-0.89988 3.115899,-1.360643 -0.380691,1.34314 -0.788033,2.687152 -1.222382,4.031605 1.255298,1.162646 2.499736,2.33005 3.731502,3.501776 -1.28229,-0.315298 -2.564926,-0.635044 -3.848598,-0.959622 0.645924,2.609209 1.210752,5.241134 1.686418,7.892118 -1.197837,-2.634673 -2.476612,-5.246448 -3.826404,-7.832497 -1.033075,0.72035 -2.077634,1.43322 -3.133582,2.138886 0.472998,-1.52032 0.912055,-3.039672 1.317824,-4.557559 -1.810094,-1.426483 -3.638393,-2.851376 -5.478913,-4.272081 z m -5.5895716,36.9831915 c -3.1473597,-5.952305 -6.778547,-11.8826695 -10.7736081,-17.7564525 4.9332581,4.516943 9.6983863,9.045609 14.1861262,13.544836 2.0491965,-4.921996 3.7216985,-9.848387 5.0443545,-14.769954 -0.02208,5.537823 -0.455781,11.126961 -1.361061,16.7384972 3.129045,1.083642 6.238103,2.143765 9.34846,3.1934273 0.0031,0.00104 0.917211,0.3117821 0.920274,0.3128251 1.641127,0.55103111 3.281751,1.09931052 4.917078,1.64394252 -4.712108,1.24471248 -9.460661,2.40713678 -14.231467,3.49627938 1.879003,6.7455285 3.097592,13.5325355 3.706631,20.2675955 -2.304249,-7.116367 -5.267426,-14.2598453 -8.946293,-21.3692356 -2.2479116,6.4542594 -5.1554174,12.9046506 -8.6240584,19.2442846 2.2238845,-6.85574 3.7962005,-13.8064522 4.6311977,-20.7276175 -3.82706347,-0.52273746 -7.6565672,-1.08435026 -11.4869309,-1.6893682 -0.6284018,-0.10024407 -1.2568831,-0.2016519 -1.8855621,-0.30424771 -1.231e-4,1.36e-5 0.5336105,-0.0592663 0.5334875,-0.0592527 4.6885711,-0.5202089 9.36295772,-1.1066938 14.0213716,-1.7655594 z" on #<Element:0x0x14d6fd0>

** (inkscape:4465): WARNING **: Event: Set attribute d to "m -19.743481,-20.978707 c 7.34771,3.503813 14.4578565,6.769314 21.5906581,9.965375 -0.1407573,-10.777922 -1.88216274,-21.385229 -4.7250834,-31.609721 5.9941372,9.7453 11.1576128,19.866154 14.9394173,30.182397 4.964128,-1.655526 9.848468,-3.418903 14.648996,-5.306043 -2.552363,5.421962 -5.55786,10.7868667 -9.034788,16.0960093 -0.08283,0.1259425 -0.165937,0.2518143 -0.249327,0.3776166 -0.148926,0.2264416 -0.29872,0.45274792 -0.449374,0.67891572 3.785894,5.27983868 7.171159,10.59896738 10.184516,15.94954238 -4.863124,-1.689706 -9.822605,-3.424534 -14.73561,-5.169973 -1.857062,11.222571 -5.560413,22.388721 -10.7571508,32.99571 2.1154702,-10.814474 2.6905443,-22.10762 1.4592548,-33.4137153 -5.6976013,2.6792173 -11.5556494,5.2794143 -17.476093,7.7904293 4.9883629,-6.00565 9.476114,-12.1314438 13.3164745,-18.25720301 0.0635955,-0.10036527 0.12702029,-0.20077612 0.19027502,-0.30123379 1.04e-6,1.2e-6 -0.0525055,-0.06119 -0.0525044,-0.061188 -5.73836228,-6.5658214 -12.11204008,-13.2449298 -18.84966108,-19.9169178 z" on #<Element:0x0x14d6ee0>

(inkscape:4465): Gtk-WARNING **: Failed to set text from markup due to error parsing markup: Error on line 1: Entity did not end with a semicolon; most likely you used an ampersand character without intending to start an entity — escape ampersand as &amp;

Jabiertxof (jabiertxof) on 2017-02-26
Changed in inkscape:
assignee: nobody → Jabiertxof (jabiertxof)
su_v (suv-lp) wrote :

On Windows 10:
- not reproduced with Inkscape 0.92.1 r15371
  (yes, there are console messages about undo, but the operation does not fail)
- reproduced with lp:inkscape r15546 (local build, devlibs64)

On OS X 10.7.5:
- not reproduced with lp:inkscape/0.92.x r15394
  (see above)

Changed in inkscape:
status: New → Confirmed
Jabiertxof (jabiertxof) wrote :

Affected more maybe all LPE in trunk, not reproduced in 0.92.x

Jabiertxof (jabiertxof) wrote :

The problem happnds when a Group has a LPE and affect to all LPE items in doc

Jabiertxof (jabiertxof) wrote :

The bug is introduced in r.15444

Jabiertxof (jabiertxof) wrote :

This patch fixes the problem. To try also whit rotate doc, the merge introducing the bug. I do some test and seems work ok.

Jabiertxof (jabiertxof) wrote :

Fixed on trunk r.15571. Not suitable to backport

Changed in inkscape:
status: Confirmed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Bug attachments