Selection tool: transformation handles vanish temporarily

Bug #1663952 reported by Hachmann
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
Inkscape
Low
Jabiertxof
0.92.x
Low
Jabiertxof

Bug Description

As requested by Jabier:

When using the selection tool, and quickly selecting different objects after each other, sometimes, the handles of the selected object aren't visible (for me, maybe every 4th to 6th time).

Handles will be shown again when you click on the object a second time (rotation handles, then), or when you select a different object.

This issue exists in (at least) 0.91 and 0.92.

=====
Originally mentioned in the comments of
Bug #1656719 “Selection tool: transformation handles vanishing”
Bug #1657874 “Missing handles after reset of rotation center”

Jabiertxof (jabiertxof)
Changed in inkscape:
assignee: nobody → Jabiertxof (jabiertxof)
Revision history for this message
su_v (suv-lp) wrote :

Confirming based on earlier comment 5 in bug #1656719.

description: updated
tags: added: selection ui
Changed in inkscape:
status: New → Confirmed
Revision history for this message
Jabiertxof (jabiertxof) wrote :

This patch fixes the bug?

Revision history for this message
su_v (suv-lp) wrote :

Jabiertxof wrote:
> This patch fixes the bug?

Based on tests with patched lp:inkscape r15507 (on Ubuntu 14.04): no, still reproduces.

Disappearing handles might possibly be related to click/drag threshold (tiny accidental drags very close to the threshold when clicking with LBM on object to select)?

jazzynico (jazzynico)
Changed in inkscape:
status: Confirmed → Triaged
importance: Undecided → Low
Revision history for this message
Jabiertxof (jabiertxof) wrote :

This patch fixes the bug

Revision history for this message
su_v (suv-lp) wrote :

A few short test sessions with patch v2 applied to lp:inkscape/0.92.x r15400 (on OS X 10.7.5) indicates that the second version works as expected to prevent a temporary loss of the transformation handles. @Hachmann - any chance you could test the patch from comment 4 too?

Revision history for this message
Hachmann (marenhachmann) wrote :

Yes, I'll try now. Might take some time ;-)

Revision history for this message
Hachmann (marenhachmann) wrote :

¡Muchas gracias, Jabier! Works perfectly (tested with most recent revision, like su_v).

Revision history for this message
Jabiertxof (jabiertxof) wrote :

Fixed in trunk r.15569. Going to backport to 0.92.x

Revision history for this message
Jabiertxof (jabiertxof) wrote :

And thanks suv and Maren for test the patch!

Revision history for this message
Jabiertxof (jabiertxof) wrote :

fixed in 0.92.x in r.15404

Changed in inkscape:
status: Triaged → Fix Committed
jazzynico (jazzynico)
Changed in inkscape:
milestone: none → 0.93
Changed in inkscape:
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers