archlinux: inkscape crashes after gtkmm upgrade (2.24.4-2 -> 2.24.5-1)

Bug #1662098 reported by Habib Ouadhour on 2017-02-06
14
This bug affects 2 people
Affects Status Importance Assigned to Milestone
Inkscape
Undecided
Unassigned
inkscape (Arch Linux)
Fix Released
Undecided
Unassigned

Bug Description

After the last update
when i try to open the preferences window the program crashed with this Messagebox Dialog
Inkscape encountered an internal error and will close now." and Close Button

When i open Inkscape from terminal to see some information i got these messages
Emergency save activated!
Emergency save completed. Inkscape will close now.
If you can reproduce this crash, please file a bug at www.inkscape.org
with a detailed description of the steps leading to the crash, so we can fix it.
Segmentation fault (core dumped)

Os : Arch Linux 64 bit
Inkscape Version : Inkscape 0.92.0 r

Backtrace :

GNU gdb (GDB) 7.12.1
Copyright (C) 2017 Free Software Foundation, Inc.
License GPLv3+: GNU GPL version 3 or later <http://gnu.org/licenses/gpl.html>
This is free software: you are free to change and redistribute it.
There is NO WARRANTY, to the extent permitted by law. Type "show copying"
and "show warranty" for details.
This GDB was configured as "x86_64-pc-linux-gnu".
Type "show configuration" for configuration details.
For bug reporting instructions, please see:
<http://www.gnu.org/software/gdb/bugs/>.
Find the GDB manual and other documentation resources online at:
<http://www.gnu.org/software/gdb/documentation/>.
For help, type "help".
Type "apropos word" to search for commands related to "word"...
Reading symbols from inkscape...(no debugging symbols found)...done.
(gdb) run
Starting program: /usr/bin/inkscape
[Thread debugging using libthread_db enabled]
Using host libthread_db library "/usr/lib/libthread_db.so.1".
[New Thread 0x7fffe6f9d700 (LWP 12033)]
[New Thread 0x7fffe679c700 (LWP 12034)]
[New Thread 0x7fffe5f9b700 (LWP 12035)]
[New Thread 0x7fffe400c700 (LWP 12036)]
[New Thread 0x7fffe380b700 (LWP 12037)]

Thread 1 "inkscape" received signal SIGSEGV, Segmentation fault.
0x00007ffff5cb05c1 in Gtk::Widget::get_allocation() const ()
   from /usr/lib/libgtkmm-2.4.so.1
(gdb) bt
#0 0x00007ffff5cb05c1 in Gtk::Widget::get_allocation() const ()
    at /usr/lib/libgtkmm-2.4.so.1
#1 0x0000000000d67a15 in Inkscape::UI::Widget::ColorSlider::_onAdjustmentValueChanged() ()
#2 0x00007ffff370e9b8 in Glib::SignalProxyNormal::slot0_void_callback(_GObject*, void*) () at /usr/lib/libglibmm-2.4.so.1
#3 0x00007ffff1c1df75 in g_closure_invoke () at /usr/lib/libgobject-2.0.so.0
#4 0x00007ffff1c30053 in () at /usr/lib/libgobject-2.0.so.0
#5 0x00007ffff1c38bcc in g_signal_emit_valist () at /usr/lib/libgobject-2.0.so.0
#6 0x00007ffff1c38faf in g_signal_emit () at /usr/lib/libgobject-2.0.so.0
#7 0x00007ffff4d192ea in gtk_adjustment_value_changed ()
    at /usr/lib/libgtk-x11-2.0.so.0
#8 0x0000000000d6d3a4 in Inkscape::UI::Widget::ColorScales::setMode(Inkscape::UI::Widget::SPColorScalesMode) ()
#9 0x0000000000d6d9ea in Inkscape::UI::Widget::ColorScales::_initUI(Inkscape::UI::Widget::SPColorScalesMode) ()
#10 0x0000000000d6ddeb in Inkscape::UI::Widget::ColorScales::ColorScales(Inkscape::UI::SelectedColor&, Inkscape::UI::Widget::SPColorScalesMode) ()
#11 0x0000000000d6dff7 in Inkscape::UI::Widget::ColorScalesFactory::createWidget(Inkscape::UI::SelectedColor&) const ()
#12 0x0000000000d6365d in Inkscape::UI::Widget::ColorNotebook::_addPage(Inkscape::UI::Widget::ColorNotebook::Page&) ()
#13 0x0000000000d63919 in Inkscape::UI::Widget::ColorNotebook::_initUI() ()
#14 0x0000000000d64663 in Inkscape::UI::Widget::ColorNotebook::ColorNotebook(Inkscape::UI::SelectedColor&) ()
#15 0x0000000000d664a5 in Inkscape::UI::Widget::ColorPicker::setupDialog(Glib::ustring const&) ()
#16 0x0000000000d66664 in Inkscape::UI::Widget::ColorPicker::ColorPicker(Glib::ustring const&, Glib::ustring const&, unsigned int, bool) ()
#17 0x0000000000c0e467 in Inkscape::UI::Widget::PrefColorPicker::PrefColorPicker() ()
#18 0x0000000000bfbd33 in Inkscape::UI::Dialog::InkscapePreferences::InkscapePreferences() ()
#19 0x0000000000b5b3a1 in Inkscape::UI::Dialog::PanelDialog<Inkscape::UI::Dialog::Behavior::FloatingBehavior>* Inkscape::UI::Dialog::PanelDialog<Inkscape::UI::Dialog::Behavior::FloatingBehavior>::create<Inkscape::UI::Dialog::InkscapePreferences>() ()
#20 0x0000000000b58309 in ()
#21 0x0000000000b59a47 in Inkscape::UI::Dialog::DialogManager::getDialog(unsigned int) ()
#22 0x0000000000b59bc3 in Inkscape::UI::Dialog::DialogManager::showDialog(unsigned int, bool) ()
#23 0x000000000095ee02 in sp_action_perform(SPAction*, void*) ()
#24 0x00007ffff1c1df75 in g_closure_invoke () at /usr/lib/libgobject-2.0.so.0
#25 0x00007ffff1c2ff82 in () at /usr/lib/libgobject-2.0.so.0
#26 0x00007ffff1c38bcc in g_signal_emit_valist () at /usr/lib/libgobject-2.0.so.0
#27 0x00007ffff1c38faf in g_signal_emit () at /usr/lib/libgobject-2.0.so.0
#28 0x00007ffff4d14710 in () at /usr/lib/libgtk-x11-2.0.so.0
#29 0x00007ffff4e9b8e9 in () at /usr/lib/libgtk-x11-2.0.so.0
#30 0x00007ffff1c1df75 in g_closure_invoke () at /usr/lib/libgobject-2.0.so.0
#31 0x00007ffff1c2ff82 in () at /usr/lib/libgobject-2.0.so.0
#32 0x00007ffff1c38bcc in g_signal_emit_valist () at /usr/lib/libgobject-2.0.so.0
#33 0x00007ffff1c38faf in g_signal_emit () at /usr/lib/libgobject-2.0.so.0
#34 0x00007ffff4d2d025 in () at /usr/lib/libgtk-x11-2.0.so.0
#35 0x00007ffff1c1df75 in g_closure_invoke () at /usr/lib/libgobject-2.0.so.0
#36 0x00007ffff1c2f95c in () at /usr/lib/libgobject-2.0.so.0
#37 0x00007ffff1c38bcc in g_signal_emit_valist () at /usr/lib/libgobject-2.0.so.0
#38 0x00007ffff1c38faf in g_signal_emit () at /usr/lib/libgobject-2.0.so.0
#39 0x00007ffff4d2bf89 in () at /usr/lib/libgtk-x11-2.0.so.0
#40 0x00007ffff4dd17ac in () at /usr/lib/libgtk-x11-2.0.so.0
#41 0x00007ffff1c1df75 in g_closure_invoke () at /usr/lib/libgobject-2.0.so.0
#42 0x00007ffff1c3037d in () at /usr/lib/libgobject-2.0.so.0
#43 0x00007ffff1c3866f in g_signal_emit_valist () at /usr/lib/libgobject-2.0.so.0
#44 0x00007ffff1c38faf in g_signal_emit () at /usr/lib/libgobject-2.0.so.0
#45 0x00007ffff4ee98cc in () at /usr/lib/libgtk-x11-2.0.so.0
#46 0x00007ffff4dcff74 in gtk_propagate_event () at /usr/lib/libgtk-x11-2.0.so.0
#47 0x00007ffff4dd032b in gtk_main_do_event () at /usr/lib/libgtk-x11-2.0.so.0
#48 0x00007ffff4a4746c in () at /usr/lib/libgdk-x11-2.0.so.0
#49 0x00007ffff1945587 in g_main_context_dispatch () at /usr/lib/libglib-2.0.so.0
#50 0x00007ffff19457f0 in () at /usr/lib/libglib-2.0.so.0
#51 0x00007ffff1945b12 in g_main_loop_run () at /usr/lib/libglib-2.0.so.0
#52 0x00007ffff4dcf3a7 in gtk_main () at /usr/lib/libgtk-x11-2.0.so.0
#53 0x00000000006b208a in sp_main_gui(int, char const**) ()
#54 0x00007ffff078f291 in __libc_start_main () at /usr/lib/libc.so.6
#55 0x00000000006ae2da in _start ()
(gdb) q
A debugging session is active.

 Inferior 1 [process 12029] will be killed.

Quit anyway? (y or n) y

su_v (suv-lp) wrote :

> After the last update

Do you have more specific information? Was this an update of Inkscape 0.92.0 as packaged by archlinux, or an update of one of the dependencies?

Possibly triggered by a recent gtkmm upgrade (2.24.4-2 -> 2.24.5-1), as was filed today in the bug tracker for archlinux:
https://bugs.archlinux.org/task/52866

tags: added: crash
Download full text (7.9 KiB)

Yes exactly as you said I'm with the version 2.24.5-1

On Feb 6, 2017 10:30 AM, "su_v" <email address hidden> wrote:

> > After the last update
>
> Do you have more specific information? Was this an update of Inkscape
> 0.92.0 as packaged by archlinux, or an update of one of the
> dependencies?
>
> Possibly triggered by a recent gtkmm upgrade (2.24.4-2 -> 2.24.5-1), as
> was filed today in the bug tracker for archlinux:
> https://bugs.archlinux.org/task/52866
>
> ** Tags added: crash
>
> --
> You received this bug notification because you are subscribed to the bug
> report.
> https://bugs.launchpad.net/bugs/1662098
>
> Title:
> Emergency save completed. Inkscape will close now.
>
> Status in Inkscape:
> New
>
> Bug description:
> After the last update
> when i try to open the preferences window the program crashed with this
> Messagebox Dialog
> Inkscape encountered an internal error and will close now." and Close
> Button
>
> When i open Inkscape from terminal to see some information i got these
> messages
> Emergency save activated!
> Emergency save completed. Inkscape will close now.
> If you can reproduce this crash, please file a bug at www.inkscape.org
> with a detailed description of the steps leading to the crash, so we can
> fix it.
> Segmentation fault (core dumped)
>
> Os : Arch Linux 64 bit
> Inkscape Version : Inkscape 0.92.0 r
>
> Backtrace :
>
> GNU gdb (GDB) 7.12.1
> Copyright (C) 2017 Free Software Foundation, Inc.
> License GPLv3+: GNU GPL version 3 or later <http://gnu.org/licenses/gpl.
> html>
> This is free software: you are free to change and redistribute it.
> There is NO WARRANTY, to the extent permitted by law. Type "show
> copying"
> and "show warranty" for details.
> This GDB was configured as "x86_64-pc-linux-gnu".
> Type "show configuration" for configuration details.
> For bug reporting instructions, please see:
> <http://www.gnu.org/software/gdb/bugs/>.
> Find the GDB manual and other documentation resources online at:
> <http://www.gnu.org/software/gdb/documentation/>.
> For help, type "help".
> Type "apropos word" to search for commands related to "word"...
> Reading symbols from inkscape...(no debugging symbols found)...done.
> (gdb) run
> Starting program: /usr/bin/inkscape
> [Thread debugging using libthread_db enabled]
> Using host libthread_db library "/usr/lib/libthread_db.so.1".
> [New Thread 0x7fffe6f9d700 (LWP 12033)]
> [New Thread 0x7fffe679c700 (LWP 12034)]
> [New Thread 0x7fffe5f9b700 (LWP 12035)]
> [New Thread 0x7fffe400c700 (LWP 12036)]
> [New Thread 0x7fffe380b700 (LWP 12037)]
>
> Thread 1 "inkscape" received signal SIGSEGV, Segmentation fault.
> 0x00007ffff5cb05c1 in Gtk::Widget::get_allocation() const ()
> from /usr/lib/libgtkmm-2.4.so.1
> (gdb) bt
> #0 0x00007ffff5cb05c1 in Gtk::Widget::get_allocation() const ()
> at /usr/lib/libgtkmm-2.4.so.1
> #1 0x0000000000d67a15 in Inkscape::UI::Widget::ColorSlider::_onAdjustmentValueChanged()
> ()
> #2 0x00007ffff370e9b8 in Glib::SignalProxyNormal::slot0_void_callback(_GObject*,
> void*) () at /usr/lib/libglibmm-2.4.so.1
> #3 0x00007ffff1c1df7...

Read more...

su_v (suv-lp) on 2017-02-06
summary: - Emergency save completed. Inkscape will close now.
+ archlinux: inkscape crashes after gtkmm upgrade (2.24.4-2 -> 2.24.5-1)
Habib Ouadhour (habt3k) wrote :

Inkscape works now with the version inkscape-0.92.0-6

Alex Valavanis (valavanisalex) wrote :

Thanks for the feedback. Closing in Inkscape, and Arch as per https://bugs.archlinux.org/task/52866

Changed in inkscape (Arch Linux):
status: New → Fix Released
Changed in inkscape:
status: New → Invalid
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers