Top bars expand with the application window size

Bug #1659253 reported by jazzynico on 2017-01-25
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
Inkscape
High
Jabiertxof

Bug Description

Reproduced on Xubuntu 16.04 with lp:inkscape rev. 15444.
Not reproduced with rev. 15443.

Steps:
1. Launch Inkscape with the default preferences (large window size in the preferences).
2. Start resizing the window so that it's height increases.
-> The height of the menu bar increases accordingly.
3. Set View>Default to move the command bar to the top of the application.
4. Resize again.
-> Now the command bar resizes instead of the menu bar.

Regression introduced (or highlighted) with rev. 15444 "merge lp:~inkscape.dev/inkscape/doc_rotate"
http://bazaar.launchpad.net/~inkscape.dev/inkscape/trunk/revision/15444

Tags: ui Edit Tag help
jazzynico (jazzynico) wrote :

@Jabier, would you be willing to take a look please?

summary: - Command bar expands with the windows size
+ Top bars expand with the application window size
houz (houz) wrote :

The problem is coming from telling the menu bar to request all available space when adding it to its parent box. Patch attached.

su_v (suv-lp) wrote :

Not reproduced as described with lp:inkscape r15444, r15447 on Ubuntu 14.04.5 LTS (GNOME desktop, Adwaita theme) - possibly requires more recent GTK+ version to reproduce (Ubuntu 14.04 ships with rather dated GTK+ 3.10.8).

--
The default setting in effect for size of new windows (with new prefs) is 'Maximized' btw, not 'Large'.

Jabiertxof (jabiertxof) wrote :

Fixed in r.15458.
Thanks @houz and @jazzynico

Changed in inkscape:
status: Triaged → Fix Released
jazzynico (jazzynico) on 2017-01-26
Changed in inkscape:
milestone: 0.93 → none
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers