cannot edit properties in the XML editor, textbox missing (Windows 10, trunk)

Bug #1658823 reported by Alvin Penner on 2017-01-23
8
This bug affects 1 person
Affects Status Importance Assigned to Milestone
Inkscape
Undecided
Unassigned

Bug Description

Windows 10, trunk rev 15423
attached is a side by side comparison of the XML editor in 0.92 (left) and trunk (right).
in trunk the textbox is missing where the properties should be shown, so they cannot be edited.

Alvin Penner (apenner) wrote :
su_v (suv-lp) on 2017-01-23
tags: added: gtk3 ui xmleditor
su_v (suv-lp) wrote :

Depending on minor version of GTK3 (and the default GTK3 theme), the resize handles for panes within a dialog are not drawn visible - usually the cursor is supposed to change when hovering a portion of the dialog where a pane can be adjusted.

Try this:
1) extend the XML Editor to maximal height in the dock (grab somewhere near the bottom edge of the dialog, and drag downwards)
2) hover the bottom border between the attributes list pane (the one in the top-right area of the dialog) and the row with attribute name + button below
3) grab the border and drag it upwards
This ought to allow to resize the pane below (increase its height) so that the entry for the attribute value becomes visible/accessible again.

AFAICT based on local tests (with 0.92.x configured and compiled using GTK3), this issue seems more problematic with GTK+ 3.18 (XML Editor attribute value entry hidden initially) than with later GTK+ 3.20 (entry is visible initially). AFAICT Windows 64bit devlibs include GTK+ 3.19.6.

Alvin Penner (apenner) wrote :

Hi,
    thanks for the info. using your instructions I got it to work. I had been using exactly the same method as I had always used on 0.92.x and before, but in this new gui it did not work. The problem is that there is literally only a 1 pixel high area where the cursor changes to the appropriate value, and if one is not incredibly patient, then the cursor will never change at all.

not sure how to proceed here. Technically the bug is fixed, yet it is inconceivable to me that any casual user will ever master this operation without help. In Inkscape 0.92.x, and before, the area where the cursor would respond was at least 3 or 4 pixels high, so that a slow scan of the mouse would always show up the correct cursor change. Now the area is 1 pixel high so that the only way to detect the change is by having the patience of Job and by knowing ahead of time that this is supposed to work.

su_v (suv-lp) wrote :

On Windows 10:
- not reproduced with Inkscape 0.92.1pre1 (GTK2, 64bit, 7z)
- reproduced with inkscape_trunk_r15113 (GTK3, 64bit, 7z) from
  http://download.tuxfamily.org/inkscape/win64/

Needs to be re-checked with newer versions of GTK3 (devlibs64: 3.19.6, latest upstream: 3.22.7).

Changed in inkscape:
status: New → Confirmed
tags: added: win64
su_v (suv-lp) wrote :

Not reproduced with Eduard's MSYS2 builds from
 http://download.tuxfamily.org/inkscape/win64/
which use a more recent stable GTK+ 3.22 build.

For GTK+ 3.19.6 as currently provided by inkscape-devlibs64, a workaround for the issue as described for the XML Editor (textbox for attribute value not accessible) is to disable the auto-hiding overlay scrollbars. In the terminal window (Command Prompt aka DOS), set this environment variable:

inkscape>set GTK_OVERLAY_SCROLLING=0

inkscape>inkscape

AFAICS this will force a minimal height (probably the minimal length of the vertical scrollbar slider) for the textbox at the bottom right of the XML Editor, and thus make it visible without having to resize the dialog's panes (I haven't found a workaround for the pane resizing issue described in comment 3 yet - apart from hoping for an update of GTK3 in inkscape-devlibs64).

Eduard Braun (eduard-braun2) wrote :

Marking as fixed in MSYS2 builds.

I filed a follow-up bug, though, as it's possible to reduce the size of the input area even more, so it's basically invisible, see bug #1723233 (This is independent of Inkscape version and gtk version though, happens in 0.92.2/master with gtk2/gtk3 alike).

Changed in inkscape:
status: Confirmed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Bug attachments