Crash on rotation of "Pattern along Path"

Bug #1658330 reported by Lucas Chamorro
14
This bug affects 3 people
Affects Status Importance Assigned to Milestone
Inkscape
Triaged
High
Unassigned

Bug Description

Hi

I'm having this crash precisely when I rotate the uppermost pattern along path (the ladder thing closest to the center molecule). Any angle does it, and it happens when I release the mouse button (the pattern rotates, but the program crashes after).
I've reproduced this 4 out of 4 times I've tried, with the file I'm attaching.
I'm running Inkscape version "0.92.0 r" in Arch Linux.

I'll try to provide any additional info you may need.

Cheers.

Revision history for this message
Lucas Chamorro (chamano) wrote :
Revision history for this message
Jabiertxof (jabiertxof) wrote :

Thanks Lucas for fill report.
here a BT with the crash: https://inkscape.org/en/paste/10610/

tags: added: 2geom
Revision history for this message
Jabiertxof (jabiertxof) wrote :

Simplified file with crash.

Revision history for this message
jazzynico (jazzynico) wrote :

Not reproduced on Windows XP (32-bit) with Inkscape 0.91 and 0.92.

Changed in inkscape:
importance: Undecided → High
Revision history for this message
jazzynico (jazzynico) wrote :

Reproduced on Xubuntu 16.04, lp:inkscape/0.92.x rev. 15325.
Not reproduced with 0.91 (same system).
Not reproduced with lp:inkscape/0.92.x rev. 15325 on Windows XP.

Changed in inkscape:
milestone: none → 0.93
status: New → Triaged
tags: added: regression transformations
removed: rotation
tags: removed: pattern
Revision history for this message
jazzynico (jazzynico) wrote :

Seems to occurs when both Snap to path and Snap cusp nodes are active in the snap toolbar.

tags: added: snapping
Revision history for this message
su_v (suv-lp) wrote :

Similar earlier reports (crash on rotational snap):
* Bug #1525498 “Crash when rotating circle with offset rotation ce...”
                (same backtrace in comment 2)
* Bug #1578919 “inkscape crashes when elements are rotated to matc...”
                (same backtrace locally, included in attached log)

Attached backtrace with lp:inkscape/0.92.x r15325 (on OS X 10.7.5), no debug build or symbols.

To post a comment you must log in.
This report contains Public information  
Everyone can see this information.

Other bug subscribers