Crash on ungrouping in v0.92

Bug #1657591 reported by Ratatosk on 2017-01-18
10
This bug affects 2 people
Affects Status Importance Assigned to Milestone
Inkscape
High
Jabiertxof
0.92.x
High
Jabiertxof

Bug Description

Bug specific to v0.92. Doesn't occur in 0.91.

When trying to work with Inkscape 0.92, I have frequently found myself with groups that cannot (ever) be ungrouped without a crash. (The workaround, of course, is to load the file in v0.91 and ungroup there instead.) Not every group is ungroupable in v0.92, but many, many, many are.

I have so far failed to find a pattern to what groups can and cannot be ungrouped. At first I thought it was an incompatibility issue between v0.91 and 0.92, but I have created lots of groups in v0.92 which then (after save and load) cannot be ungrouped in v092. On the other hand, I have in v0.92 successfully ungrouped many groups created in v0.91.

So, rather than to give any steps to reproduce such a group (though I suspect a save & load is required), I just attach a small SVG with a group that I cannot ever ungroup in v0.92 without a crash. (In v.091, I have no problems ungrouping it.)

Tried with Inkscape version 0.92.0+66 for Ubuntu (14.04 and 16.10).

Related branches

Ratatosk (ratatosk) wrote :
su_v (suv-lp) wrote :

Crash not reproduced with Inkscape 0.92.0 r15299 (on OS X 10.7.5) with default (new) preferences.

Could you attach the current user's preferences file to the bug report, to allow investigation whether the reported issue could be tied to specific preference settings? Possibly you have a particular dialog open (e.g. the Path Effects dialog), restored from last session?

On Linux, Inkscape's preferences file is at
  $HOME/.config/inkscape/preferences.xml

tags: added: crash
Ratatosk (ratatosk) wrote :

Sorry, "ungroupable" should read "NOT ungroupable", of course.

Ratatosk (ratatosk) wrote :

Attached is the preferences of the fresh Inkscape 0.92 installation I just made on Ubuntu 16.10, where I also get the crash.

su_v (suv-lp) wrote :

On ungroup, I do see this console message consistently with 0.92.0 r15299:

** (inkscape:74172): CRITICAL **: void sp_lpe_item_update_patheffect(SPLPEItem *, bool, bool): assertion 'SP_IS_LPE_ITEM (lpeitem)' failed

Out of probably around 20 tests (some with new prefs, some with my personal prefs, some with only the path effects editor restored from last session otherwise default, some with the prefs from comment 4), I got two crashes with 0.92.0 r15299 (still on OS X 10.7.5), one backtrace (regular build, without debug symbols unfortunately) attached.

At this point, I can't tell what triggered these two crashes: I tried loading the file directly via command line argument, reloading it into an empty document window from within Inkscape via 'File > Recent', opening it into a new window from within inkscape (current document dirtied with a scribbled path), but nothing seems to allow to consistently reproduce it intentionally.

If you happen to have other files around which crash on ungroup in Inkscape 0.92 - could you check whether there are objects inside such groups which use a path effect (e.g. Pattern Along Path), or attach them to the bug report?

su_v (suv-lp) wrote :
Changed in inkscape:
status: New → Confirmed
Ratatosk (ratatosk) wrote :

Those path effects again. I think you are right. In every group I had a problem with, there were no doubt some objects with path effects. And groups without them, I don't think I ever had problems with. The latter ones are relatively few, which is why I haven't considered it much. (I really _like_ the "shaped paths" that you can draw with pen or bezier tool.)

If I come across anything to contradict it, I will tell you, but for now, I think we can indeed assume path effects to be a factor in this.

Note though that I have many groups with path effects that (for some reason) I can ungroup without problems. Also, in my experience (on Ubuntu), this seems completely non-random. Either a group has a problem or it hasn't. And if it has (like the one in my test file), I can NEVER ungroup it with v0.92. (I have tried that one many, many times now.)

I don't know whether there is something specific about the Linux build, or the Ubuntu build 0.92.0+66 (received via the inkscape.dev/stable ppa) causing this, or there are indeed some preferences I could set to avoid this issue. The latter case would be nice to find out about, even if just as a workaround until 0.92 works as reliably as 0.91 did for me.

su_v (suv-lp) on 2017-01-19
tags: added: livepatheffects
su_v (suv-lp) wrote :

Also reproduced (still not as consistent in a quick test as by the original reporter) on Ubuntu 14.04.5 LTS with trunk PPA r15392 and local trunk build lp:inkscape r15422 (backtrace without debug symbols attached of crash on second run).

Jabiertxof (jabiertxof) on 2017-01-19
Changed in inkscape:
assignee: nobody → Jabiertxof (jabiertxof)
jazzynico (jazzynico) on 2017-01-20
Changed in inkscape:
status: Confirmed → Triaged
importance: Undecided → High
Jabiertxof (jabiertxof) wrote :

fixed in trunk in r.15424 and in 0.92 in 15323

Changed in inkscape:
status: Triaged → Fix Committed
Ratatosk (ratatosk) wrote :

Yay! Having downloaded and compiled Inkscape 0.92.x revision 15325 (after figuring out how to do it; the page https://inkscape.org/en/develop/getting-started/ was very helpful), I now have a working 0.92 sans the bugs I reported – just a few days after I did it. (And some other bugs too are gone.)

Thank you so much to Jabiertxof for the swift fixing of this! Thanks also to su_v and jazzynico for helping! For that matter, thank you to all the Inkscape developers. You are doing great work!

jazzynico (jazzynico) on 2017-01-21
Changed in inkscape:
milestone: none → 0.93
Jabiertxof (jabiertxof) wrote :

Thanks so much for the feedback ratatosk!

theozh (theozh) wrote :

Hi,
I don't know whether it is the same bug...
I also observe reproduceable crashing when ungrouping. Inkscape 0.92.1 r15371, Win7/64

A SVG file (map from OpenStreetMap, size ca. 4.5 MB) with a group of ~6000 objects, some of them are extremely large in size (in terms of pixels, not MBs)
More details can be found here...
http://www.inkscapeforum.com/viewtopic.php?f=29&t=32095&p=97460#p97460

theozh (theozh) wrote :

...that's what I get as error message in the console:

(inkscape.exe:6704): glibmm-ERROR **:
unhandled exception (type std::exception) in signal handler:
what: basic_string::_M_construct null not valid

Emergency save activated!
Emergency save completed. Inkscape will close now.
If you can reproduce this crash, please file a bug at www.inkscape.org
with a detailed description of the steps leading to the crash, so we can fix it.

Hachmann (marenhachmann) wrote :

(the above file ungroups fine in 0.91. In 0.92, processor load goes up and it never finishes (but doesn't crash for me)

theozh (theozh) wrote :

I can confirm. Quickly installed 0.91 r13725 on Win7/64 again. No problem with ungrouping.
So it seems a 0.92 issue and not an issue with my PC.

su_v (suv-lp) wrote :

The SVG version of the OSM map (comment 12) has no Inkscape live path effects, so the crash discussed in comments 12-15 is AFAICT unlikely to be related to the crash tracked here (bug #1657591) based on the original report.

Attached is a reduced case of that OSM map which triggers the crash on ungroup (AFAICT it is related to pattern fills). The reduced test case can be used by affected users to search the bug tracker for other existing related reports, or to file a separate new report (based on quick tests with archived builds, that regression / crash appears to have been introduced between r14159 (no crash) and r14165 (crash) - possibly it was exposed with the merge in r14160).

theozh (theozh) wrote :

Thank you @su_v for your investigations. I will file a new report...

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers