Regression: main window location is not stored

Bug #1654464 reported by uwestoehr on 2017-01-06
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
Inkscape
Low
Patrick Storz
0.92.x
Low
Patrick Storz

Bug Description

This is a regression compared to Inkscape 0.91:

- check in the preferences under Interface -> Windows that the option to store the window position for every file is set.
 OK, let's test this:
- open the attached simple SVG file with Inkscape 0.92
- change Inkscape's main window so that it consumes 1/4 of the screen area of your monitor
- move the Window to the lower right corner of your screen
- if you like save the opened SVG file
- close Inkscape

- now open the same SVG file again
result: Inkscape is opened at the upper left corner of the screen in a different size
expected result: It is opened at the lower right corner with the size of about 1/4 of the screen area

This is a regression to older Inkscape releases.

=====
Tested and reproduced by the reporter with Inkscape 0.92 (32bit, 64bit) on 3 different Windows 7 64bit PCs.

uwestoehr (uwestoehr) wrote :
su_v (suv-lp) wrote :

Please add information about OS/platform to the bug description, thank you. Do you use a single monitor or a multi-monitor setup?

(Window size and position can be affected e.g. by the desktop/window manager)

Changed in inkscape:
status: New → Incomplete
tags: added: ui
Patrick Storz (ede123) wrote :

Is this the same issue as bug #195683?

uwestoehr (uwestoehr) wrote :

> Please add information about OS/platform to the bug description

My OS is Windows 7, 64 bit. The bug occurs with the 64bit version of Inkscape 0.92 but also with the 32 bit version

p.s. In all other bugtrackers I know I have several inout fields when reporting bugs to do this. Your bug tracker has not and does also not ask for these info. Moreover when reporting bugs it is proposing me possible similar bugs but all of them were already fixed or invalid - I'll report these issues as new bugs.

uwestoehr (uwestoehr) wrote :

> Is this the same issue as bug #195683?

bug #195683 is about negative x or y position values. I can conform this but. What I reported here is the general case: no matter where I place the window (positive position values) the image sizes AND position is not stored. Maybe both bugs have the same reason.

This bug is however new for me in Inkscape 0.92, therefore i tagged it as regression. I tested it on 3 different Windows 7 64bit PCs and on all 3 I get this bug with 0.92. Since every PC has a different graphics card it is definitely not a graphics driver issue.

su_v (suv-lp) on 2017-01-07
description: updated
Changed in inkscape:
status: Incomplete → New
description: updated
Patrick Storz (ede123) wrote :

This bug should be fixed in r15507
http://bazaar.launchpad.net/~inkscape.dev/inkscape/trunk/revision/15507

Please confirm if that is the case.

Changed in inkscape:
assignee: nobody → Eduard Braun (eduard-braun2)
jazzynico (jazzynico) on 2017-02-11
Changed in inkscape:
importance: Undecided → Low
milestone: none → 0.93
status: New → Fix Committed
tags: added: regression
Changed in inkscape:
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Bug attachments