DXF import messes up with hatches

Bug #1653707 reported by Mattia Rizzolo on 2017-01-03
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
Inkscape
Medium
Unassigned
inkscape (Debian)
Confirmed
Unknown

Bug Description

Originally reported at https://bugs.debian.org/822579

I noticed an issue with the DXF import function. It may mess up badly
with the hatches, when importing DXF files.

Please take a look at the attached minimal test case.
File section.dxf has been created with package librecad: it includes
a polyline (that consists of a segment and two circular arcs)
and a hatch.
File section.pdf has been created with the PDF export function of
librecad. The hatch looks OK.

Now, if I try to import the DXF with inkscape:

  $ inkscape section.dxf

I see the polyline rendered fine, but the hatch is totally messed up!
The hatch pattern is not the right one and the hatched area is
absolutely different from the original one!
Please see file section_from_nkscape.pdf, obtained from inkscape.

I've seen this with both 0.91 and 0.92~pre4

Mattia Rizzolo (mapreri) wrote :
Mattia Rizzolo (mapreri) wrote :
Mattia Rizzolo (mapreri) wrote :
Changed in inkscape (Debian):
status: Unknown → New
su_v (suv-lp) on 2017-01-03
tags: added: dxf importing
Changed in inkscape (Debian):
status: New → Confirmed
jazzynico (jazzynico) wrote :

Confirmed on Windows XP (32-bit), Inkscape 0.48.5, 0.91 and 0.92.
The hatches show correctly when open in LibreCad.

Changed in inkscape:
importance: Undecided → Medium
status: New → Triaged
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.