'Scale elements': masks and clipPaths with multiple references are scaled incorrectly

Bug #1653230 reported by su_v on 2016-12-30
8
This bug affects 1 person
Affects Status Importance Assigned to Milestone
Inkscape
Medium
Unassigned
0.92.x
Medium
Unassigned

Bug Description

If a mask or clip in a legacy file (90dpi) is referenced (used) by multiple objects (e.g. after having duplicated masked or clipped objects with 'Ctrl+D'), the option to 'Scale elements' to 96dpi may scale the mask or clipPath content for each referenced case instead of only once.

Steps to reproduce:
1) launch inkscape
2) open the attached SVG file
3) choose 'Scale elements' when asked about DPI change

--> the masks/clipPaths of the clipped / masked groups are incorrect in position and size (check also in outline view mode).

4) change preferences for transforms to 'Preserved'
5) revert the file and apply 'Scale elements' again

--> check the preserved transforms applied for the dpi change: it ought to be "scale(1.0666667)" for both the objects in the masked/clipped group as well as for the mask/clipPath. The content of the mask/clipPath however is scaled higher: "scale(1.3808409)".

1.3808409 = 1.0666667^5 # the mask/clip is referenced 5 times.

Reproduced with Inkscape 0.92pre5 r15288 on OS X 10.7.5.

su_v (suv-lp) wrote :
su_v (suv-lp) wrote :

Reproduced with Inkscape 0.92+devel r15374 on Ubuntu 14.04.5 LTS.

Changed in inkscape:
status: New → Confirmed
jazzynico (jazzynico) wrote :

Also reproduced on Windows XP (32-bit), lp:inkscape/0.92.x rev. 15301.

Changed in inkscape:
status: Confirmed → Triaged
milestone: none → 0.92
jazzynico (jazzynico) on 2017-01-04
Changed in inkscape:
milestone: 0.92 → 0.92.1
su_v (suv-lp) wrote :

Not reproduced with Inkscape 0.92+devel r15407 (default prefs) on Ubuntu 14.04 with 'Scale test - all'.

su_v (suv-lp) wrote :

Attached is a what seems a variation of the original test case: multiple clones referencing the same clipPath element - the document does not correctly rescale using Inkscape 0.92+devel r15407 (default prefs) on Ubuntu 14.04 with 'Scale test - all'.

Not sure how it relates to this or one of the other reports about 'Scale elements' (my head is rather dizzy after all the testing ;-) )

The clipped clones themselves, while referencing the same path, seem also to be scaled differently (at least in outline view mode?

su_v (suv-lp) wrote :

The example of comment #6 can be reproduced with stable 0.92.x too (leave current group, unlock, unhide all, select all across layers, scale with mouse from center (Shift) with ratio locked (Ctrl)); it seems that the scaling of this specific document structure (depending on the exact selection and current layer(?)) has "worsened" in 0.92.x compared to 0.91, but neither version allows to scale the drawing content of the original version [1] while keeping appearance the same unless the original of the clones is excluded from scaling (on a hidden and locked layer in the original version).

My conclusion for now is that if 'Scale test - all' is to replace 'Scale elements' (in 0.92.x), the new scaling option needs more testing (if the project wants to determine a set of 'known issues'): testing whether known issues with current 'Scale elements' are exposed or not is helpful, but does not cover other issues that might be more specific to 'Scale test - all' (aka Inkscape's scaling of a compound selection).

--
[1] https://openclipart.org/detail/269770/kaleidoscope-test

jazzynico (jazzynico) on 2017-01-12
Changed in inkscape:
importance: Undecided → Medium
jazzynico (jazzynico) on 2017-02-16
Changed in inkscape:
milestone: 0.92.1 → 0.93
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers