gradient mesh cloning and editing parent results in instant crash

Bug #1651096 reported by Pétery Tamás on 2016-12-19
18
This bug affects 3 people
Affects Status Importance Assigned to Milestone
Inkscape
High
Unassigned
0.92.x
High
Unassigned

Bug Description

When cloning an object with a gradient mesh,
editing the parent's mesh results in instant crashing.
On win 10 64bit 0.92pre3 15195.

Brynn (brynn4inks) wrote :

It seems like we don't have anyone addressing new bugs lately. But when they do, they'll probably ask you for system info, and possible a test file.

Pétery Tamás (lazur) wrote :

Added info to the description.

description: updated
Alvin Penner (apenner) wrote :

could you attach a sample svg file for testing?

Alvin Penner (apenner) wrote :

okay, scratch that.
crash reproduced on Windows 10, Inkscape 0.92pre3 15195 (32 bit exe)
using attached dwawing

Changed in inkscape:
status: New → Confirmed
Pétery Tamás (lazur) wrote :

Clone on the right, parent on the left -move one of the parent mesh nodes.

Alvin Penner (apenner) wrote :

yes, this particular bug report is confirmed. I have reproduced the crash.

<offtopic>
could you give your bug reports more specific titles, so that they can be distinguished from each other. I count 6 reports with the same name. From a bug triage point of view, it would be reasonable to assume that these are all the same report, in which case one report would get all the attention, and the other five would be ignored. I assume that this is not what you want.
</offtopic>

Pétery Tamás (lazur) wrote :

Yes that's a good point on the report names, I had that thought as well. Will try to come up with more specific names.

Pétery Tamás (lazur) on 2016-12-19
summary: - gradient mesh issue
+ gradient mesh cloning and editing parent results in instant crash
su_v (suv-lp) wrote :

Possibly related to similar issue tracked for regular gradients in
* Bug #453067 “Crash editing gradient of clone parent”
  https://bugs.launchpad.net/inkscape/+bug/453067

Reptorian (reptillia-39) wrote :

I have this issue on Inkscape .92 pre5 r15287 under Windows 10 x64 Home Edition

------
Operating System used, and Inkscape version used is attached inside the .svg file.

To reproduce -

1) Make a simple gradient mesh for testing purpose
2) Clone it
3) Touch and move any nodes/handles
4) Look at the program crash
------

jazzynico (jazzynico) wrote :

Also reproduced on Windows XP, lp:inkscape/0.92.x rev. 15302.

Bug #453067 is not fixed, but no longer crashes thanks to the workaround implemented rev. 13465 (http://bazaar.launchpad.net/~inkscape.dev/inkscape/trunk/revision/13465).

Changed in inkscape:
importance: Undecided → High
milestone: none → 0.92
status: Confirmed → Triaged
jazzynico (jazzynico) on 2017-01-04
Changed in inkscape:
milestone: 0.92 → 0.92.1
jazzynico (jazzynico) on 2017-02-16
Changed in inkscape:
milestone: 0.92.1 → 0.93
Nathan Lee (nathan.lee) wrote :
Changed in inkscape:
status: Triaged → Invalid
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.