text not displaying in 0.92pre3

Bug #1644299 reported by jmeidal on 2016-11-23
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
Inkscape
Undecided
Unassigned

Bug Description

Text and image displays in 0.91 but not in 0.92pre2 and 0.92pre3--both in Win10 x64

jmeidal (jmeidal) wrote :
Alvin Penner (apenner) wrote :

thank you for taking the time to file a report.
the problem is not reproduced on Windows 10 using Inkscape 0.92pre3 15195 (32 bit, exe build)
attached is a screenshot of my Inkscape result. Is this what you expected to see?

(Note that IE11 does not display the text, but that is likely because it is flowed text, not an Inkscape problem)

jmeidal (jmeidal) wrote :

I just uninstalled .92pre3 and installed .91, both x64 on Win10

Here's my screenshot which shows more elements than in .92. I forgot I deleted some shapes which I also had seen issue with transferring between the two.

Alvin Penner (apenner) wrote :

thanks for the screenshot.
- problem confirmed on Win 10, Inkscape 0.92pre3 15195
- the problem appears to be related to the font-size. I went through the flowed-text boxes by hand and arbitrarily reduced the font size by about a factor of 3, say from 36 to 10. Then the text became visible. The result is attached here. Flowed-text boxes will sometimes refuse to show the text at all if the font size is too large.

Changed in inkscape:
status: New → Confirmed
Alvin Penner (apenner) wrote :

It is possible that the problem is related to the question of who takes precedence when there are multiple specifications of the same font size for the same text. In the file "business card template", at the bottom left, there are four lines of text which are normally visible in Inkscape 0.97 but are not all visible in Inkscape 0.92.

At the top of these lines in the XML tree there is a flowroot with the specification:
flowRoot7771 - font size = 36px

The individual lines each have the specification:
flowPara7777 - font size = 9.74565125px
flowPara7779 - font size = 9.74565125px
flowPara7781 - font size = 9.74565125px
flowPara7783 - font size = 9.74565125px

In Inkscape 0.92 these lines are normally not visible. If I manually edit flowroot7771 to have a font-size 9.75, then all four lines of text become visible. It appears that Inkscape 0.92 is not correctly interpreting the order of precedence of various specifications of font-size.

su_v (suv-lp) on 2016-12-05
tags: added: regression text
su_v (suv-lp) wrote :

Can be "fixed" with extension from bug #1652340, output attached (please check).

su_v (suv-lp) on 2017-01-12
summary: - text and image not displaying in 0.92pre3
+ text not displaying in 0.92pre3
su_v (suv-lp) wrote :

The file based on the original report opens as expected with Inkscape 0.92.1 (see attached).

Issues with baseline spacing of text in legacy files (last edited with <= 0.91) which persist in Inkscape 0.92.1 should be filed separately (for new reports, please provide the original files which have not yet been resaved with Inkscape 0.92.x).

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers