Pattern along Path renders differently on circle / circular path

Bug #1643408 reported by Hachmann on 2016-11-21
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
Inkscape
Undecided
Jabiertxof

Bug Description

Tested with 0.92pre2.

(wanted to check if a freeze with mounting memory usage I got in 0.91 persists. The memory leak is gone, fortunately, but I found a different problem.)

The LPE Pattern along Path renders differently in 0.92pre2 than in 0.91 for circles.
It looks broken in 0.92pre2, see attached screenshots and file (zipped).

Hachmann (marenhachmann) wrote :
su_v (suv-lp) on 2016-11-21
tags: added: livepatheffects
su_v (suv-lp) wrote :

Testing with archived builds (on OS X 10.7.5):
- not reproduced with lp:inkscape rev <= 14224,
- crash on load with lp:inkscape 14228 <= rev < 14299,
- reproduced with lp:inkscape rev >= 14299

Revisions 14226, 14299 had been major 2geom updates.

--
Replaces (hidden) comment 2 to correct rev numbers of 2geom updates.

tags: added: 2geom
Changed in inkscape:
status: New → Confirmed
Jabiertxof (jabiertxof) on 2016-11-21
Changed in inkscape:
assignee: nobody → Jabiertxof (jabiertxof)
Jabiertxof (jabiertxof) wrote :

Fixed in trunk r.15263 and in 0.92.x in r.15208

Changed in inkscape:
status: Confirmed → Fix Committed
status: Fix Committed → Fix Released
su_v (suv-lp) on 2016-11-21
tags: removed: 2geom
Hachmann (marenhachmann) wrote :

Wow, that was impressively fast, su_v and Jabier! Thank you!

Jabiertxof (jabiertxof) wrote :

You are welcome!

su_v (suv-lp) wrote :

PaP LPE on paths with end nodes which have the handles retracted (cusp nodes without handle in the node editor) has further deteriorated with this fix (at least in 0.92.x with r15208) - it's basically unusable (due to the randomness of incorrect output which can appear or disappear even by nudging a node or handle minimally) without extracting at least a minimal handle for both start and end nodes.

Jabiertxof (jabiertxof) wrote :

Confirmed and fixed in trunk r.15309 and in 0.92.x in r.15246

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers