Inkscape 0.92pre Crash on Exporting Keymap under Windows 7

Bug #1639701 reported by Duarte Ramos on 2016-11-07
24
This bug affects 3 people
Affects Status Importance Assigned to Milestone
Inkscape
High
Patrick Storz
Nominated for 0.92.x by Patrick Storz

Bug Description

With the Inkscape 0.92pre2 15127 snapshot from the Inkscape Website, using Edit User Preferences > Interface > Keyboard Shortcuts > Export causes inkscape 0.92 to crash.

Either immediately after pressing escape, or some times a few 'ghost windows' pop up. One can't see the content of the window nor the right-click menu, but copy-pasting the text reveals the window is showing a "Inkscape encountered an internal error and will close now." hidden message.

It will let you browse for a location and save there, but the file is never created, and closing the lingering window will make Inkscape finally force-quit.

I am using the snapshot from the Inkscape Gallery Inkscape 0.92pre2 15127, under Windows 7 64 bits.

Duarte Ramos (duarte-framos) wrote :
description: updated
jazzynico (jazzynico) on 2016-11-07
Changed in inkscape:
importance: Undecided → High
tags: added: crash shortcuts
jazzynico (jazzynico) wrote :

Not reproduced on Xubuntu 16.04, lp:inkscape rev. 15219 and lp:inkscape/0.92.x rev. 15155.
Not reproduced on Windows XP (32-bit) with lp:inkscape/0.92.x rev. 15155.

Duarte Ramos (duarte-framos) wrote :

OK, so I can confirm this also happened in 0.91 too, I had a fuzzy idea of reporting something similar before https://bugs.launchpad.net/inkscape/+bug/1408154

The fact that no file is created seems to be caused by there being no changes in the default keyboard shortcut file, thought the crash still seems to be unwanted behavior.

Tested again a bit further it it was caused by having portable settings defined with `SET INKSCAPE_PORTABLE_PROFILE_DIR=.\Settings` but no change starting directly from the exe.

The crash is not consistent, if you notice on the attached GIF, it only happpens from time to time. When it doesn't Inkscape UI becomes unfocused or unresponsive and has to be minimized and maximized to be usable again. After a few exports attempts it will eventually crash.

If you notice in the attached gif there is also a weird blank window floating above the preferences window whenever it is unfocused, though it is a minor glitch and probably unrelated to the crash.

Let me know if you need any further information

Alvin Penner (apenner) wrote :

confirmed on Windows 10, running Inkscape 0.92pre2 15127 (Oct 21 2016) (32 bit .exe build)

I do not actually get a crash, instead I just get a failure to produce the output file, with the following DOS error messages:
(I have checked to confirm that this file does not exist in this location)

C:\Program Files (x86)\Inkscape>inkscape

** (inkscape.exe:12340): WARNING **: Can't open file: C:\Users\username\AppData\Roaming\inkscape\keys\default.xml (doesn't exist)

** (inkscape.exe:12340): WARNING **: Unable to read keyboard shortcut file
C:\Users\username\AppData\Roaming\inkscape\keys\default.xml

Changed in inkscape:
status: New → Confirmed
Alvin Penner (apenner) wrote :

instead, the file C:\Program Files (x86)\Inkscape\share\keys\default.xml does exist

jazzynico (jazzynico) wrote :

@Alvin, I can confirm the failure to produce the output file when exporting an unchanged keymap. If you modify a key assignment, a local file is created and then correctly exported (with the local changes only, not the whole keymap).
But I'm not sure it's the same issue Duarte reported.

description: updated
Patrick Storz (ede123) wrote :

Issue confirmed in Inkscape 0.92.1 Inkscape 0.92.1 r15371 (64-bit) as well as current master.

The issue happens when using the *native file dialog* on Windows.
With the gtk dialog I can export just fine.

Unfortunately I was not able to create a gdb backtrace as Inkscape suddenly does not crash anymore when run through gdb...

Patrick Storz (ede123) wrote :

OK, source found (it's in src/shortcuts.cpp): "saveDialog->addFileType("All Files", "*");"

Patrick Storz (ede123) wrote :

Issue fixed in
https://gitlab.com/inkscape/inkscape/commit/49ea08c12ce0f931ba7fc79d8ad9f2fa42a7dca7

(we happily wrote characters beyond the end of a char[1], so crashes were literally pre-programmed)

Changed in inkscape:
milestone: none → 0.93
assignee: nobody → Eduard Braun (eduard-braun2)
status: Confirmed → Fix Committed
tags: added: backport-proposed
Duarte Ramos (duarte-framos) wrote :

Thanks for the fix Eduard, appreciate it :)

Duarte Ramos (duarte-framos) wrote :

Many thanks for the fix, appreciate it :)
Looking forward to a new build.

su_v (suv-lp) on 2017-07-17
tags: removed: backport-proposed
Qantas94Heavy (qantas94heavy) wrote :

Fix released in 0.92.2.

Changed in inkscape:
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers