Envelope Deformation miserable failures

Bug #1598009 reported by Parcly Taxel on 2016-07-01
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
Inkscape
Undecided
Jabiertxof

Bug Description

[Trisquel 7.0, Inkscape trunk r15003]
1. Draw any path.
2. Make a clone of that path and move it somewhere else.
3. Apply the Envelope Deformation LPE to the original path.

First bug: both the original and clone are reduced to points, even though the LPE is successfully applied.

From step 1:
2. Make a group with only the drawn path, then transform it anyway you like.
3. Apply the Envelope Deformation LPE to the transformed group.

Second bug: in the LPE editor, the green paths for controlling the deformation are in the wrong place, even though the blue lines showing the transformed bounding box of the group the LPE is applied to are correct.

(Bug 1 is now pretty much a joke bug)

description: updated
su_v (suv-lp) wrote :

"First bug" likely a duplicate of bug #1299461.

Jabiertxof (jabiertxof) wrote :

Dont undertand you very well with bug 2. Please help me.

Jabiertxof (jabiertxof) wrote :

I see.

Jabiertxof (jabiertxof) wrote :

Seems a hard to fix problem, without broken "visible" things. If you see the point positions in the LPE widget, they are correctly applied but influenced by the group transform. If we can separate the skew and the rotation from a affine transform, maybe we can have a fix but this is not posibol.

Happend in all LPE with point parameters. The "strange" position of knots happends only in skew and rotale transforms.

Also happends on apply this kinds of transforms to a path when the LPE is active. In this case you can reset the effect to get ok the knots/point parameters.

The bug is specialy visible (miserable?) in perspective/envelope because his logical origin is a box. For example in Lattice 2 is not much problem.

su_v (suv-lp) wrote :

AFAICT the "second bug" of the “miserable failures” (what a miserable summary line ;-) ) is a regression introduced recently in trunk:
- not reproduced with Inkscape 0.48.5, 0.91
- not reproduced with 0.92pre1 (prerelease tarball)
- not reproduced with archived trunk builds rev <= 14965
- reproduced with archived trunk builds rev >= 14979

Related commit history:
https://bazaar.launchpad.net/~inkscape.dev/inkscape/trunk/changes/14979

Likely related to changes in rev 14975:
https://bazaar.launchpad.net/~inkscape.dev/inkscape/trunk/revision/14975

The regression does not reproduce locally after rebuilding current trunk (r15003) with the changes of rev 14975 reverted.
All tests have only been done (in a new doc, with new prefs) as described in the bug description: a single path, wrapped in a group, the group moved, 'Envelope Deformation' path effect applied, node editor invoked for one of the bend paths via button in the Path Effects dialog.

@Jabiertxof - any chance you could revisit the changes of rev 14975 and investigate whether this regression could be avoided?

Changed in inkscape:
status: New → Confirmed
tags: added: regression
Jabiertxof (jabiertxof) wrote :

Forget my coment, Im speaking about perspective/envelope LPE.
su_v go to fix it.

Jabiertxof (jabiertxof) wrote :

Fixed in r.15004

Changed in inkscape:
assignee: nobody → Jabiertxof (jabiertxof)
status: Confirmed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers