‘Wrap when cycling objects in z-order’ works when unchecked

Bug #1589420 reported by Sylvain Chiron on 2016-06-06
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
Inkscape
Low
Mc

Bug Description

When the setting ‘Wrap when cycling objects in z-order’ is unchecked (Preferences > Behavior > Selection), the wrapping still works when going from bottom to top (but not with the other direction).

I also wonder whether the selection of the first object is buggy… I would advise to select the topmost object when going top to bottom, and the deepest object if starting in the other direction (no matter the state of the setting).

jazzynico (jazzynico) on 2016-06-06
tags: added: preferences selection
Sylvain Chiron (frigory) on 2016-06-06
description: updated
jazzynico (jazzynico) wrote :

Reproduced on Windows XP (32-bit), Inkscape trunk rev. 14968.
Not reproduced with 0.91.

Changed in inkscape:
importance: Undecided → Low
status: New → Triaged
milestone: none → 0.92
tags: added: regression
jazzynico (jazzynico) wrote :

To narrow down a bit, it can be reproduced with rev. 14538, but not with rev. 14506.

Changed in inkscape:
assignee: nobody → jazzynico (jazzynico)
status: Triaged → In Progress
jazzynico (jazzynico) wrote :

Regression introduced rev. 14520 (http://bazaar.launchpad.net/~inkscape.dev/inkscape/trunk/revision/14520).
Patch in progress.

jazzynico (jazzynico) wrote :

Hmm, the patch isn't as obvious as I expected. I'm going to ask the committer.

Changed in inkscape:
assignee: jazzynico (jazzynico) → nobody
status: In Progress → Triaged
Mc (mc...) wrote :

Assigning to myself, I'll try to take a look next week

Changed in inkscape:
assignee: nobody → Mc (mc...)
Sylvain Chiron (frigory) wrote :

In 0.91, the preference works well, but the first selection when selecting from bottom is still not what I would expect.

Mc (mc...) wrote :

attached a patch for testing

jazzynico (jazzynico) wrote :

Patch from comment #7 tested successfully on Xubuntu 16.04, Inkscape trunk rev. 14987.

But there's a regression (compared to 0.91) with the way the selected object is taken into account in the list (as explained by Sylvain comment #6).

Sylvain Chiron (frigory) wrote :

Comment #6 doesn't speak of a regression… I said the first selected object was not the right one when selecting from bottom, and this is also the case in 0.91 from my tests.

Mc (mc...) wrote :

committed to r14988

Changed in inkscape:
status: Triaged → Fix Committed
Bryce Harrington (bryce) on 2017-01-10
Changed in inkscape:
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Patches