Inkscape crash when selecting one item with paint order and the other without it

Bug #1557192 reported by Jabiertxof on 2016-03-14
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
Inkscape
High
Jabiertxof

Bug Description

Inkscape crash when selecting one item with paint order and the other without it.
Debian Testing Inkscape 0.91+devel

Steps to reproduce:
Draw a path, set his pain order.
Select pen tool
Draw a path
Switch to select tool
Select both items
Inksacpe crash with the attached BT

Jabiertxof (jabiertxof) wrote :
Changed in inkscape:
assignee: nobody → Jabiertxof (jabiertxof)
Jabiertxof (jabiertxof) wrote :

This file fix the bug

jazzynico (jazzynico) on 2016-03-15
tags: added: selection styles
Changed in inkscape:
importance: Undecided → High
milestone: none → 0.92
status: New → In Progress
jazzynico (jazzynico) wrote :

Patch tested successfully on Windows 7, Inkscape trunk rev. 14707 (32-bit).
Thanks Jabier!

Jabiertxof (jabiertxof) wrote :

Thanks to you for take the time to try!

Jabiertxof (jabiertxof) on 2016-03-15
Changed in inkscape:
status: In Progress → Fix Committed
Jabiertxof (jabiertxof) wrote :

fix in r.14708

Changed in inkscape:
status: Fix Committed → Fix Released
Jabiertxof (jabiertxof) wrote :

Closing as 'Fix Released' since the issue did not affect a stable release version.

jazzynico (jazzynico) on 2016-05-30
Changed in inkscape:
milestone: 0.92 → none
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers