Voronoi Extension: Delaunay triangulate can get fill color from sources

Bug #1553497 reported by Jabiertxof on 2016-03-05
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
Inkscape
Wishlist
Jabiertxof

Bug Description

Is easy a non perfect way - if there is a perfect one :)- add fill color to Delaunay triangles. In next files I attach the extendion modiffied to hadle it.
Here are a slow video working:
https://youtu.be/sVEx4ydX0j8

Related branches

Jabiertxof (jabiertxof) wrote :

This add fill ans a thin border to fills, optionaly

description: updated
jazzynico (jazzynico) on 2016-03-15
summary: - Voronoi Extension: Delaunay triangulate can get fill color from souces
+ Voronoi Extension: Delaunay triangulate can get fill color from sources
Changed in inkscape:
assignee: nobody → Jabiertxof (jabiertxof)
importance: Undecided → Wishlist
status: New → In Progress
tags: added: extensions-plugins
Jabiertxof (jabiertxof) wrote :

Thanks Jazzynico for get into!

jazzynico (jazzynico) wrote :

Tested on Windows XP (32-bit), with inkscape trunk rev. 14718.

The colors seems to be set randomly. Is it an expected behavior?
Apart from it, the new feature looks good, and I see no regression.

Jabiertxof (jabiertxof) wrote :

Thanks very much for try my patch Jazzynico.
I Just add another version to make optional the randomize in each apply.

jazzynico (jazzynico) wrote :

New patch tested successfully on Windows7, with inkscape trunk rev. 14747.
Thanks!

Changed in inkscape:
milestone: none → 0.92
Jabiertxof (jabiertxof) wrote :

Thanks very much for testing again. When have a short time I put on trunk.

Jabiertxof (jabiertxof) wrote :

Fix commited. Thanks @jazzynico

Changed in inkscape:
status: In Progress → Fix Committed
Bryce Harrington (bryce) on 2017-01-10
Changed in inkscape:
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers