Break Apart dont handle well stroke with in documents different than px

Bug #1552765 reported by Jabiertxof on 2016-03-03
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
Inkscape
Medium
Jabiertxof

Bug Description

Breaking apart paths with strokes defined, the width of the strokes are scaled if document units are not "px"
Debian testing.

Steps to reproduce:
Create a compound path -> give stroke to them -> break apart -> the stroke with change
Attached a testing SVG
This also affect all tools using break apart, for example eraser tool

jazzynico (jazzynico) wrote :

Not reproduced on Windows XP (32-bit), Inkscape trunk rev. 14683.

tags: added: eraser units
Jabiertxof (jabiertxof) wrote :

Test SVG example

summary: - Eraser tool dont hadle well stroke with in documents different than px
+ Break Apart dont handle well stroke with in documents different than px
description: updated
description: updated
tags: added: break-apart
removed: eraser
Jabiertxof (jabiertxof) on 2016-03-04
description: updated
jazzynico (jazzynico) wrote :

Finally reproduced on Windows XP, and Inkscape trunk rev. 14683. Just forgot to activate the break apart mode...

Changed in inkscape:
importance: Undecided → Medium
milestone: none → 0.92
status: New → Triaged
jazzynico (jazzynico) wrote :

And of course it can also be consistently reproduced with the Path > Break apart command.

jazzynico (jazzynico) wrote :

Also reproduced with 0.91.
Seems to be related to the transform: scale() attribute. The bug doesn't occur when I break apart a path created with the pen tool, with no transform. But the same path is affected if I use the eraser instead of the Path command.

Jabiertxof (jabiertxof) wrote :

This fix the bug.

Changed in inkscape:
assignee: nobody → Jabiertxof (jabiertxof)
jazzynico (jazzynico) on 2016-03-20
Changed in inkscape:
status: Triaged → In Progress
jazzynico (jazzynico) wrote :

Thanks for the new patch!

It's a bit better, but not fixed yet:
 - The stroke width still changes (20 mm before, 19,844 mm after).
 - When using dashes, they are quite severely affected (not reproduced with 0.91).

Jabiertxof (jabiertxof) wrote :

Thanks for testing jazzynico! I just compile another patch, I think today is solved.

Jabiertxof (jabiertxof) wrote :

This fix the bug.

Jabiertxof (jabiertxof) wrote :

Patch applied on r14765

Changed in inkscape:
status: In Progress → Fix Committed
status: Fix Committed → Fix Released
status: Fix Released → Fix Committed
Bryce Harrington (bryce) on 2017-01-10
Changed in inkscape:
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers