Measure tool creates multiple measurements when switching document window while tool active

Bug #1541963 reported by su_v on 2016-02-04
8
This bug affects 1 person
Affects Status Importance Assigned to Milestone
Inkscape
Low
Jabiertxof

Bug Description

Steps to reproduce:

1) launch current trunk (default prefs, default new doc)
2) open a second document window (Ctrl+N)
3) arrange the two document windows side by side
4) in New document 1: switch to the measure tool, start measuring
5) repeat step 5 in New document 2
6) repeat several times while keeping the measure tool the active tool in both windows:
switch document window (Ctrl+TAB), click and drag on the canvas

With each switch of document window (desktop), the earlier measure path is retained, and a new one is drawn. The remnants of the the earlier measurement are persistent (e.g. on zooming) and not editable. The multiple measurements of the last window closed are also present in the new default document opened after closing all open document windows (with Ctrl+W) in the current session.

First encountered (and consistently reproduced) with
 Inkscape 0.91+devel r14630 on OS X 10.7.5

su_v (suv-lp) wrote :

Random screenshot of reported issue (Inkscape 0.91+devel r14630 on OS X 10.7.5)

su_v (suv-lp) on 2016-02-04
description: updated
Jabiertxof (jabiertxof) on 2016-02-06
Changed in inkscape:
assignee: nobody → Jabiertxof (jabiertxof)
Jabiertxof (jabiertxof) wrote :

Thanks su_v I just fix it and commit to trunk.

Changed in inkscape:
status: New → Fix Committed
su_v (suv-lp) wrote :

JFTR: fix was committed in rev 14632.
Closing as 'Fix Released' since the issue did not affect a stable release version.

@Jabiertxof - thx a lot!

Changed in inkscape:
importance: Undecided → Low
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers