Crash when stretching a rect snapped to a guide (rev >= 14363)

Bug #1541727 reported by chmapak on 2016-02-04
36
This bug affects 5 people
Affects Status Importance Assigned to Milestone
Inkscape
High
Diederik van Lierop

Bug Description

Inkscape "inkscape-14630-Cairo-1.14.6+patch" (Win) version crashes when a rectangle is re -sized keeping snap to grid option on.
When the rectangle snapped to a vertical guide on East end and the west end of rectangle is stretched towards west side then the west side suddenly snaps to eastern end guide and app crashes. The screenshot of crash is enclosed.

chmapak (chmapakbhumia) wrote :
su_v (suv-lp) wrote :

Reproduced with Inkscape 0.91+devel r14630 on OS X 10.7.5 with new default prefs in a new document based on the default template (en_US).

Based on tests with archived builds:
- not reproduced with rev <= 14358,
- reproduced with rev >= 14363;
the regression seems likely exposed by or related to the changes in rev 14363.

* Changelog:
http://bazaar.launchpad.net/~inkscape.dev/inkscape/trunk/changes/14363

* Related commit:
Revision 14363: Refactoring of the code that handles transformations and snapping in the selector tool and the node tool. Splitting large chunks of code into some small classes, and eliminating some wrapper methods which were all just too similar
http://bazaar.launchpad.net/~inkscape.dev/inkscape/trunk/revision/14363

tags: added: crash snapping
Changed in inkscape:
importance: Undecided → High
milestone: none → 0.92
status: New → Confirmed
tags: added: regression
su_v (suv-lp) wrote :

Backtrace with debug build (r14624).

possible related to 2geom - I recall seeing crashes in do_append in other reports:
#9 0x0000000100f788a6 in Geom::Path::do_append (this=0x116c7e9f0, c=0x116c6fc70) at ../../src/2geom/path.cpp:987

tags: added: 2geom
su_v (suv-lp) on 2016-02-04
summary: - Inkscape crash while doing an activity
+ Crash when stretching a rect snapped to a guide (rev >= 14363)
su_v (suv-lp) wrote :

See also test case in new duplicate report bug #1541893.

Changed in inkscape:
status: Confirmed → Triaged

Thanks chmapak and ~suv, I will take care of this.

Changed in inkscape:
assignee: nobody → Diederik van Lierop (mail-diedenrezi)
Alexey (allkhor) wrote :

It's the same or maybe related of this.
https://youtu.be/3TmZZhOvGDg

Step to reproduce:
1) Open attached file.
2) Enabled snap bounding boxes->snap to edges of a bounding box -> snap bounding box corners
3) Scale rectangle as on video.
4) When all be a white color, release the mouse button, or press the Escape key on keyboard.
5) Crash...

terminate called after throwing an instance of 'Geom::ContinuityError'
  what(): lib2geom exception: Non-contiguous path (../../src/2geom/path.cpp:1043)

Alexey (allkhor) wrote :
Filip Dominec (fdominec) wrote :

Thank you; I could reproduce the bug in Inkscape "0.91+devel r", too, through snapping one edge to the same horizontal (or vertical) coordinate as the opposite edge is, thus producing a zero-area rectangle.

When you try to resize this rectangle again, Inkscape behaves in a weird way: it moves the whole rectangle at half speed of your mouse. It looks like if the resizing action divided equally into both overlapping edges. The correct behaviour should be to randomly pick one of them to resize, and keep the second one at its original place.

This anomaly may also be the cause of Inkscape crashing.

Please try revision 14905; I believe that this has been fixed

Changed in inkscape:
status: Triaged → Fix Committed
Alexey (allkhor) wrote :

Not reproduced more, thank you!

Bryce Harrington (bryce) on 2017-01-10
Changed in inkscape:
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers