Measure work slow on arcs

Bug #1540518 reported by Jabiertxof on 2016-02-01
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
Inkscape
Medium
Jabiertxof

Bug Description

When using meassure tool over a circle, meassure works slow.
Seems to be a crossing match problem on arcs, because editing the path to remove the arcs become too much speed on tool.

Steps to reproduce:
Create a new document
Draw a circle
Meassure it -> slow response
Convert to path and move the handles -> better response

Related branches

Jabiertxof (jabiertxof) on 2016-02-01
description: updated
tags: added: circle meassure tool
su_v (suv-lp) on 2016-02-01
tags: added: measuretool
removed: circle meassure tool
tags: added: performance
summary: - Meassure work slow on arcs
+ Measure work slow on arcs
su_v (suv-lp) wrote :

Could you provide details about the settings used for the measure tool, or attach your preferences file? A quick test (new prefs, new doc) doesn't reproduce a major performance difference for me (r14630).

Jabiertxof (jabiertxof) wrote :

It happen for example with all toggles disabled. Are you sure remove the arcs moving all 4 /8 handles?

Jabiertxof (jabiertxof) wrote :

You only need to move one handle: Video with the problem:
https://www.youtube.com/watch?v=IbOl8FO5BBY

Is a old computer but I also notice this in a new one with SSD.
Both with debian stretch and last trunk.
I see tweenk work on arcs on 2geom... maybe this fix it when merge it to inkscape. And maybe fix 1490324.

su_v (suv-lp) wrote :

On 2016-02-06 17:09 (+0100), Jabiertxof wrote:
> Are you sure remove the arcs moving all 4 /8 handles?

Yes, I'm aware of how to trigger a rewrite of the path data in the node tool (which converts arc commands into cubic bezier curve commands), and I usually double-check the value of 'd' via XML Editor. I'll retest later (my initial tests got interrupted by bug #1541963 when I wanted to compare measuring the two types of paths side by side).

su_v (suv-lp) wrote :

@Jabiertxof: what I can reproduce is an increasingly poorer performance with the circle depending on zoom level: the closer I'm zoomed in, the worse the performance gets. The absolute size of the circle does not appear to have an influence on this. The behavior strikes me as odd - I had not assumed that e.g. the precision with which the measure tool detects paths and intersections would depend on the zoom level ...

Does this match the observed issue on your system?

su_v (suv-lp) wrote :

Another contributing factor seems to be toggling OFF "Show measures between items" (ON with default new prefs).

Jabiertxof (jabiertxof) wrote :

Ok, maybe is not a crossing problem, try to fix. Thanks for check it.

Jabiertxof (jabiertxof) wrote :

Solved and with a way that make the tool too fast!

Changed in inkscape:
assignee: nobody → Jabiertxof (jabiertxof)
status: New → Fix Released
su_v (suv-lp) on 2016-02-07
Changed in inkscape:
importance: Undecided → Medium
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers