Some LPE on clippath and/or masked item crash inkscape

Bug #1540070 reported by Jabiertxof on 2016-01-31
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
Inkscape
High
Jabiertxof

Bug Description

I have a crash on apply LPE to a item with clippath applied, also happens with masked items.

It happen in all LPE whith clip and paths active, for example "bend path"

Attached a example SVG, and the output of GDB backtrace.

Seems a problem on bounding box calulation, not sure is related to my default boost instalation.

It happens on Debian Testing in 0.91+devel r14627.

Steps to reproduce:
1.-Open Inkscape Trunk.
2.-Open attached SVG
3.-Select the unique item
4.-Apply bend path

=====
This is a follow-up report to:
Bug #1241902: "Clips and masks fail to update in live effects"
https://bugs.launchpad.net/inkscape/+bug/1241902

Jabiertxof (jabiertxof) wrote :
Jabiertxof (jabiertxof) wrote :

Basic SVG that crash

description: updated
description: updated
summary: - LPE on clip and path crash inkscape
+ LPE on clippath and mask crash inkscape
summary: - LPE on clippath and mask crash inkscape
+ LPE on clippath and masked item crash inkscape
su_v (suv-lp) on 2016-01-31
tags: added: clipping
removed: cliping
Jabiertxof (jabiertxof) on 2016-01-31
summary: - LPE on clippath and masked item crash inkscape
+ LPE on clippath and/or masked item crash inkscape
summary: - LPE on clippath and/or masked item crash inkscape
+ Some LPE on clippath and/or masked item crash inkscape
description: updated
Jabiertxof (jabiertxof) on 2016-01-31
description: updated
su_v (suv-lp) on 2016-01-31
Changed in inkscape:
importance: Undecided → High
milestone: none → 0.92
status: New → Confirmed
tags: added: regression
su_v (suv-lp) wrote :

On OS X 10.7.5:
- not reproduced with Inkscape 0.91 r13725
- reproduced with Inkscape 0.91+devel r14627

Based on tests with archived builds:
- not reproduced with rev <= 13638,
- reproduced with rev >= 13646;
the crash seems to have been exposed with changes in the merge of the experimental branch in rev 13641.

* Relevant changelog:
https://bazaar.launchpad.net/~inkscape.dev/inkscape/trunk/changes/13646

* Likely relevant commit:
Revision 13641: Merge experimental
https://bazaar.launchpad.net/~inkscape.dev/inkscape/trunk/revision/13641

--
replaces comment 3 to fix typo in revno

su_v (suv-lp) on 2016-01-31
description: updated
Jabiertxof (jabiertxof) on 2016-01-31
Changed in inkscape:
assignee: nobody → Jabiertxof (jabiertxof)
Jabiertxof (jabiertxof) wrote :

This attachment fix the bug, simplify the code and also allow for mixed type of LPE, clip and mask frendly and not.

Jabiertxof (jabiertxof) wrote :

Any problem to apply this to trunk?

Jabiertxof (jabiertxof) on 2016-03-02
Changed in inkscape:
status: Confirmed → Fix Released
status: Fix Released → Fix Committed
Jabiertxof (jabiertxof) wrote :

Fixed in r.14678

Changed in inkscape:
status: Fix Committed → Fix Released
Jabiertxof (jabiertxof) wrote :

Closing as 'Fix Released' since the issue did not affect a stable release version.

jazzynico (jazzynico) on 2016-05-30
Changed in inkscape:
milestone: 0.92 → none
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers