zh_CN translation updates for 0.91.x and devel HEAD (0.92.x)

Bug #1520884 reported by Mingye Wang on 2015-11-29
8
This bug affects 1 person
Affects Status Importance Assigned to Milestone
Inkscape
Low
Mingye Wang

Bug Description

See the attached tarball (just use the latest one) for more information.

These files are sent in a single xzipped tarball simply for size advantages from solid compression.

Stats from msgfmt:
$ for i in inkscape_*.zh_CN.po; do printf '%s\t' "$i"; msgfmt -o /dev/null -vc --check-accelerator=_ "$i"; done
inkscape_0_91.zh_CN.po 7297 translated messages, 19 fuzzy translations, 88 untranslated messages.
inkscape_0_92.zh_CN.po 7799 translated messages, 56 untranslated messages.

Apparently I forgot about 0.92.x. Well, you can run msgmerge…

summary: - zh_CN translation updates for 0.9.1 and devel HEAD
+ zh_CN translation updates for 0.91.x and devel HEAD
Mingye Wang (artoria2e5) wrote :

Oh, so HEAD is 0.92.x. Great.

summary: - zh_CN translation updates for 0.91.x and devel HEAD
+ zh_CN translation updates for 0.91.x and devel HEAD (0.92.x)
Mingye Wang (artoria2e5) wrote :

Oh, well, I should have changed the language teams to <email address hidden>. Here is a new one.

I changed Project-Id-And-Version to match the branch status too.

description: updated
description: updated
Mingye Wang (artoria2e5) wrote :

Fixes:
1. translations for layer menu, lmy199(whatever) spotted this error.
2. an extra for '_Close' caused by not pressing Alt when trying to mark a bookmark in POedit.

description: updated
jazzynico (jazzynico) on 2015-11-29
Changed in inkscape:
assignee: nobody → Mingye Wang (arthur2e5)
importance: Undecided → Low
milestone: none → 0.92
status: New → In Progress
jazzynico (jazzynico) wrote :

Thank you very much for your great update (now 99% translated!).
The zh_PO files are now updated in the trunk (rev. 14493) and the 0.91.x branch (rev. 13850).

Don't hesitate to reuse the same report (just change the status) if you wish to update your translation again.

Changed in inkscape:
status: In Progress → Fix Committed
jazzynico (jazzynico) wrote :

@Mingye Wang - We currently have two open issues related to Chinese language and fonts:

Bug #620844 "Fix several bugs in Simplified Chinese translation" <https://bugs.launchpad.net/inkscape/+bug/620844>
Bug #166344 "dialog boxes in 0.41 cannot show Chinese characters" <https://bugs.launchpad.net/inkscape/+bug/166344>

Would you be willing to take a look and confirm that the first issue is fixed with your translation update and that the second only affects Inkscape?
Thanks again!

Mingye Wang (artoria2e5) wrote :

Sure. Grabbing launchpad branch pots and preparing to run diff.

Since we (uh, my friends and I) have been through everything I think these should be ok…

Mingye Wang (artoria2e5) wrote :

Apparently I have nothing to do with traditional chinese, or Chinese (Taiwan) [zh_TW] things. Well, I still tested it using current Inkscape 0.91, and it works for me.

The new zh_CN one doesn't look like really interesting -- it looks like we already have all their fixes. But there was one newly translated string in their submission which does not appear in 0.92.x but in 0.91.x, so I merged it in.

Additionally, this comes with a minor formatting change for both 0.91.x and 0.92.x. Consult diff for more info.

Mingye Wang (artoria2e5) wrote :

Ah, Bai told me I should have used 'read through' instead of 'been through' in #8… Is it acceptable to say 'Laugh-Out-Loud' in a launchpad bug tracker entry?

jazzynico (jazzynico) wrote :

> Is it acceptable to say 'Laugh-Out-Loud' in a launchpad bug tracker entry?

Why not ? ;)

Thanks for your comments on the other reports.

Changed in inkscape:
status: Fix Committed → In Progress
jazzynico (jazzynico) wrote :

Translation updated in the 0.91.x branch (rev. 13852) and trunk (rev. 14498).
Thanks!

Changed in inkscape:
status: In Progress → Fix Committed
Aron Xu (happyaron) wrote :

Attached is the updated inkscape translations for 0.91.x and 0.92.x branches.

jazzynico (jazzynico) wrote :

Translation updated in the 0.91.x branch (rev. 13861) and trunk (rev. 14746).
Thanks!

Mingye Wang (artoria2e5) wrote :

Oh my... Aron you are killing the ellipses and violating the rule again.
(https://inkscape.org/en/contribute/translations/)

> use the proper Unicode codepoint for "..." - "…". In German at least, a space comes before this ellipsis.

I don't want to repeat my very emotional comments at https://bugzilla.gnome.org/show_bug.cgi?id=758122 (and https://mail.gnome.org/archives/gnome-i18n/2015-November/msg00040.html) here in launchpad bugzilla.

Mingye Wang (artoria2e5) wrote :

diff is telling me that there are indeed improvements.

Oh headaches... JeffBai and I spent man-hours in total checking the punctuations, and now we have to do that again (not that bad -- msgfilter should be actually usable this time, since at least the periods '。' and commas ',' are good). No offence but this reminds me of the rule 'mix good edits with your Vandalism' in https://zh.wikipedia.org/wiki/User:Morrigan/%E7%A0%B4%E5%A3%9E%E5%B7%A5%E4%BD%9C%E5%B0%8F%E7%B5%84.

As an aside, try to learn from this particular mistake:

> msgctxt "Symbol"
> msgid "Gas Station"
> -msgstr "加油站"
> +msgstr "加气站"

And I will try to find some time in June (oh yeah June) to fix all the micro-typographical problems, including '90x50', parentheses (maybe) and all these unfortunate ellipses.

Aron, please, please, please, add a step called 'read how-to-translate-this-project' to your translation rush. It's OK to disregard my fork of your guide, but really please check out the upstream instructions first.

<repeat 'upstream' for 30 times here using Steve Ballmer's voice>

Mingye Wang (artoria2e5) wrote :

Anyway, thanks for all these work and improvements.

Aron Xu (happyaron) wrote :

Hi,

I changed the punctuations deliberately cuz your rules never applied to GNOME translations, and I see it pointless on pushing another rule again even you believe they are better or more correct.

Not mentioning which form of the ellipses should be used, adding another space before the ellipses is in question. The problem is whether you want to have the same rules applied to one project across different languages, or you want every language use a common rule across projects. I would vote for the consistency of language rather than project while you are trying hard to violate such effort in recent times - I'm not against forking the document but I'm really against saying upstream (for 30 times) is everything, ;-)

Mingye Wang (artoria2e5) wrote :

> The problem is whether you want to have the same rules applied to one project across different languages, or you want every language use a common rule across projects.

You may want to stop GNOME's evil attempt of forking the English language and making it use Unicode ellispses first. You, KDE, and Microsoft all use three dots!
(Sorry for that Oxford comma. That's a fork!)
(Typographical traditions? Is that even a thing? In our world there is only old sch00l ASCII tradition.)

> adding another space before the ellipses is in question

Chinese is not German, please read carefully.

> never applied to GNOME
Pray do read *GNOME* HIG (that linked page in the bug report). You are applying three-dots even when msgid is using Unicode ellipses. Completely intolerable.

(Oops, the war has spread to Launchpad! Fortunately I haven't signed the CoC!)

Liu Shuyu (liushuyu-011) wrote :

Well, most rules have been set up by you, my dear Aron.
I have compared the two editions of the translation guide, actually, the changes are not significant. In other words, you are trying to blame the `you` of the past, who you now consider as, say, the @arthur2e5, who just attempted to contribute his/her tiny effort. If you need some physiological help about how to accept the changes between `you` in the past and the `you` at the present, I recommend you to meet an experienced physiologist.

BTW, as it is said in République: watch your step

Mingye Wang (artoria2e5) wrote :

Well liushuyu, I don't think it's particularly helpful to settle the war here. (Actually, what are you doing? You told me to pretend that I didn't know you and... <HEADACHE>)

Regarding the `physiological help' part, I do need something to stop me from getting too angry about all these (which leads to oversight of some actually helpful changes). Just like what me current personal description on https://launchpad.net/~arthur2e5 says, things may go wild on me and ray guns can be helpful at times.

Just wait for June.

Mingye Wang (artoria2e5) wrote :

Didn't mean to say 'settle'. Should have been something like 'spread' or even 'fight'.

Regarding the l10n guide part, the only relevant changes here is in sec 3.1 "Punctuations" (using my section numbers, well):

<<<<<<< MINE
* '...' ellipses should be left intact, because *historically* the translators found it hard to tell menus (may only use '...' according to the old rules) from normal text (where Unicode ellipses are good). But don't change Unicode ellipses to triple-period.

...

Many projects (e.g. GNOME HIG, Inkscape) also have their own respective micro-typographical conventions. If you noticed some features (e.g. &copy; but not 'x', and use of curly quotes) indicating such changes in the source text, you should mind your micro-typography too.
=======
* '...' ellipses should be always translated to '...', because it's hard to tell menus from normal text, where only the latter can use Chinese [Unicode] ellipses '……'.
>>>>>>> UbuntuCN

(This is actually a pointless discussion; All I can say are already there in GNOME.)

Mingye Wang (artoria2e5) wrote :

One last thing to say before I drop the mic[1]:
Please, make artists and designers see what they want to see in the programs they use (Inkscape) and the programs they designed (GNOME).

I use GIMP and Inkscape personally, and was often forced to tolerate the quality of the translations you submitted or committed (sometimes I just switch to en_US, ha). I decided to complete Inkscape translation partly to make sure my happy mood of making funny sticker packs are not ruined by things like L10n.

Many good/beautiful things are fragile. In Chinese there is a slang: one drop of rat manure ruins the whole pot of porridge. I sincerely hope that zh_CN L10n coordinators like you can understand what users like me feel when looking at the UIs in Chinese.

[1]: May be a reference to Gmail April Fool's Day joke, which caused quite some mess..

Mingye Wang (artoria2e5) wrote :

Pedantic correction for comment 22: "&copy; but not (C), &times but not 'x'".

Bryce Harrington (bryce) on 2017-01-10
Changed in inkscape:
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.