alt + scroll with layers causes hang with 100% cpu usage

Bug #1519547 reported by insaner on 2015-11-25
8
This bug affects 1 person
Affects Status Importance Assigned to Milestone
Inkscape
High
Mc

Bug Description

Steps to reproduce:

-In a new doc create a rectangle.
-Create a new layer, and add a rectangle in this new layer such that it overlaps with the first rectangle.
-Hold down the Alt key while you scroll above the rectangles.

Result:

Inkscape begins to use 100% CPU usage, and becomes unresponsive. I did not wait to see if it ever completes the task.

gdb backtrace:

http://pastebin.com/VtLG9FzS

su_v (suv-lp) wrote :

On OS X 10.7.5:
- not reproduced with Inkscape 0.91 r13725,
- reproduced with Inkscape 0.91+devel r14488

tags: added: performance selection
Changed in inkscape:
importance: Undecided → High
milestone: none → 0.92
status: New → Confirmed
tags: added: regression
su_v (suv-lp) wrote :

Based on tests with archived trunk builds (on OS X 10.7.5):
- not reproduced with 0.91+devel rev <= 14335,
- reproduced with 0.91+devel rev >= 14336;
this regression seems to be related with the merge in rev 14336:
https://bazaar.launchpad.net/~inkscape.dev/inkscape/trunk/changes/14336

* Merge faster touch select
  https://bazaar.launchpad.net/~inkscape.dev/inkscape/trunk/revision/14336

Changed in inkscape:
status: Confirmed → Triaged
Mc (mc...) on 2015-11-25
Changed in inkscape:
assignee: nobody → Mc (mc...)
Mc (mc...) wrote :

Fixed in r14489.

Changed in inkscape:
status: Triaged → Fix Committed
Bryce Harrington (bryce) on 2017-01-10
Changed in inkscape:
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers