Path with LPE in selection set causes crash

Bug #1517740 reported by Jaydon Soo on 2015-11-19
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
Inkscape
High
Mc

Bug Description

Steps to reproduce:
Create a path
Add (presumably) any LPE ("Fill between many" was the main one tested)
Attempt to add the path to a selection set

Tested on Inkscape r14319 64 bit, r14477 64 bit, and r14476 32 bit. Windows 10 Pro 64 bit.

Also, some earlier revision seems to handle LPEs in selection sets fine, but I don't know the revision number of that copy.

Jaydon Soo (jaydonsky) on 2015-11-19
description: updated
su_v (suv-lp) wrote :

Reproduced with Inkscape 0.91+devel r14476 on OS X 10.7.5.

The crash seems to affect all object types with url references to other objects (clones, linked offsets, path eeffects …).

Based on tests with archived builds:
- not reproduced with 0.91+devel rev < 14244,
- reproduced with 0.91+devel rev >= 14245;
this regression seems to be related to the changes in
Revision 14245: Fix for circular references detection in almost all cases, fixing bug #167247 and a few of its duplicates.
http://bazaar.launchpad.net/~inkscape.dev/inkscape/trunk/changes/14245

tags: added: crash selection
Changed in inkscape:
importance: Undecided → High
milestone: none → 0.92
status: New → Confirmed
tags: added: regression
su_v (suv-lp) wrote :

Full backtrace debug build r14476 (OS X 10.7.5)

Mc (mc...) wrote :

Fixed in rev 14478, sorry for any inconvenience

Changed in inkscape:
status: Confirmed → Fix Released
assignee: nobody → Mc (mc...)
su_v (suv-lp) on 2015-11-19
Changed in inkscape:
milestone: 0.92 → none
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers