Save as optimized svg generates invalid svg output

Bug #1516538 reported by Erik Dahlström on 2015-11-16
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
Inkscape
High
Eduard Braun
Scour
Undecided
Eduard Braun

Bug Description

Steps to reproduce bug:

1. Create new document in inkscape
2. Click the text tool
3. Write something, press return, write something, press return, write something
4. Select the three lines of text and set a new font and font-size
5. Save as optimized svg, and make sure the "group collapsing" option is unchecked, and the "create groups for similar attributes" is checked

The generated output svg has a structure like this:

<svg>
  <text>
    <g>
      <tspan>...</tspan>
      <tspan>...</tspan>
      <tspan>...</tspan>
    </g>
  </text>
</svg>

The g tag in this case makes browsers not render the tspans. It's also invalid svg markup, since <g> isn't allowed as a child of <text>.

su_v (suv-lp) on 2015-11-16
tags: added: exporting svg
su_v (suv-lp) wrote :

Reproduced as described with Inkscape 0.91 r13725 and 0.91+devel r14472 on OS X 10.7.5 (both include Scour 0.26+r220).

Changed in inkscape:
importance: Undecided → High
status: New → Confirmed
Eduard Braun (eduard-braun2) wrote :

Fixed in scour 0.35 [1]

See copy of this bug on GitHub for details
https://github.com/scour-project/scour/issues/96

[1] https://pypi.python.org/pypi/scour

Changed in inkscape:
status: Confirmed → Fix Committed
Changed in scour:
status: New → Fix Released
Changed in inkscape:
assignee: nobody → Eduard Braun (eduard-braun2)
Changed in scour:
assignee: nobody → Eduard Braun (eduard-braun2)
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.