strong visual tearing / rendering glitches while moving objects

Bug #1510704 reported by Lukas F. Hartmann on 2015-10-27
14
This bug affects 3 people
Affects Status Importance Assigned to Milestone
Inkscape
Medium
Unassigned

Bug Description

Whenever I move an object -- simple or complex doesn't matter -- the object is redrawn in visually overlapping discontinous bands that make the correct placing of objects very hard.

Changing rendering options (threads or memory) doesn't seem to have an impact.

Example:

Non-moving object: http://dump.mntmn.com/inkscape-glitch1.jpg
Object while moved: http://dump.mntmn.com/inkscape-glitch2.jpg

Inkscape 0.91 r13725
Debian 8
Linux irata-debian 4.1.0-0.bpo.1-rt-amd64 #1 SMP PREEMPT RT Debian 4.1.3-1~bpo8+1 (2015-08-12) x86_64 GNU/Linux

Hardware is 13" Retina Macbook Pro 2013

Desktop Environment xfce4

su_v (suv-lp) on 2015-10-27
tags: added: performance renderer-cairo
Lukas F. Hartmann (luzas) wrote :

Here is my "test case" as per request

su_v (suv-lp) wrote :

Reproduced on OS X 10.7.5 (GTK+/X11) with Inkscape 0.91 r13725, 0.91+devel r14430 (tested with cairo 1.14.2 and cairo git master).

- turning off caching does have no effect;
- the rendering glitches don't reproduce if zooming out further;
- removing the stroke (or converting it to path) does reduce the rendering glitches.

Changed in inkscape:
importance: Undecided → Medium
status: New → Confirmed
trlkly (trlkly) wrote :

I can confirm this bug on Windows 7 as well. It's worst in the 32-bit version, but it also shows up in the 64-bit version. It's actually best in an old 0.91 beta I still happened to have, but it still happens.

I note that GIMP had this same problem in 2.8. I believe it was fixed in 2.8.4. I don't think it's purely a performance issue, even if it is only noticeable with larger amounts of data. It seems to me more like it's painting in the wrong order.

It sucks, because 0.91 has a few nifty features, but it's unusable in this state. Seems strange to me that it had such a long beta and this wasn't caught.

Mc (mc...) wrote :

Tackled by psychon in commit 8825db4e6132bada6cd86b93e6591aa3a53e86b7

Changed in inkscape:
status: Confirmed → Fix Committed
milestone: none → 0.93
su_v (suv-lp) on 2017-07-01
tags: added: backport-proposed
Patrick Storz (ede123) wrote :
tags: removed: backport-proposed
Changed in inkscape:
milestone: 0.93 → 0.92.2
assignee: nobody → Max Gaukler (mgmax)
Max Gaukler (mgmax) on 2017-08-01
Changed in inkscape:
assignee: Max Gaukler (mgmax) → nobody
Patrick Storz (ede123) wrote :

Sorry, wrong commit... (gnore comment #6)

Backported to 0.92.x in
https://gitlab.com/inkscape/inkscape/commit/8825db4e6132bada6cd86b93e6591aa3a53e86b7

Patrick Storz (ede123) wrote :

I'm really goo ad copy pasting wrong links apparently.

Commit in ä#7 was the original commit to master, the commit in 0.92.x is
https://gitlab.com/inkscape/inkscape/commit/5fed544de3310e3b5a8326aaaabd0a30412d3b63

(If I still got it wrong please fix it since I'm apparently incapable of getting this right ;-) )

jazzynico (jazzynico) on 2017-08-31
Changed in inkscape:
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers