Program crashed after adding new Chinese fonts

Bug #1508928 reported by Simon Li on 2015-10-22
10
This bug affects 1 person
Affects Status Importance Assigned to Milestone
Inkscape
High
Patrick Storz

Bug Description

I am using Inkscape 0.91 on Windows 8.1, 64 bit.

After I had added new Chinese fonts to the Windows, the Inkscape program shut down automatically when I click at Text> Text and Font, or clicking the Font dialogue box in Inkscape. The problem still exists after I have deleted the newly added font and even reinstalled Inkscape. I am sure the new fonts can work because I can use them without any problem in Microsoft Word.

I have uploaded one of the font file for you to try at the link below, and also attached the same file here:
https://www.filepicker.io/api/file/hYopCHUjS5uPU6tStIDd

I am very frustrated now because I cannot even change English fonts, please offer help ASAP, thanks...

Simon Li (simon-lsm) wrote :
su_v (suv-lp) wrote :

Which installer package did you use for Inkscape 0.91 - 32bit or 64bit?

On 2015-10-22 15:17 (+0200), Simon Li wrote:
> The problem still exists after I have deleted the newly added font

Just to be sure - please verify that all versions of the font are fully uninstalled. Apparently Windows tends to keep multiple old versions around, ignored by the native font backend but still visible and active to the font backend which Inkscape 0.91 uses on Windows:
http://www.inkscapeforum.com/viewtopic.php?f=22&t=18770&p=71390#p71487

Changed in inkscape:
status: New → Incomplete
tags: added: crash fonts

Hi, it is 64 bit. Should I try also 32 bit?

I have tried to add few more fonts to Windows, the problem gets even worse:
Inkscape cannot open! Now I have deleted all the newly added fonts, then I
can open Inkscape (with 10 sec delay), but it still crashes when I click
Text> Text and Font.

I have posted this issue on a forum, some people told me to use other file
managers instead of the Windows file manager to install and delete the
fonts, and use CCleaner to clean the registry etc. I tried them all but the
problem still exists.

On Fri, Oct 23, 2015 at 1:43 AM, ~suv <email address hidden> wrote:

> Which installer package did you use for Inkscape 0.91 - 32bit or 64bit?
>
> On 2015-10-22 15:17 (+0200), Simon Li wrote:
> > The problem still exists after I have deleted the newly added font
>
> Just to be sure - please verify that all versions of the font are fully
> uninstalled. Apparently Windows tends to keep multiple old versions around,
> ignored by the native font backend but still visible and active to the font
> backend which Inkscape 0.91 uses on Windows:
> http://www.inkscapeforum.com/viewtopic.php?f=22&t=18770&p=71390#p71487
>
> ** Changed in: inkscape
> Status: New => Incomplete
>
> ** Tags added: crash fonts
>
> --
> You received this bug notification because you are subscribed to the bug
> report.
> https://bugs.launchpad.net/bugs/1508928
>
> Title:
> Program crashed after adding new Chinese fonts
>
> Status in Inkscape:
> Incomplete
>
> Bug description:
> I am using Inkscape 0.91 on Windows 8.1, 64 bit.
>
> After I had added new Chinese fonts to the Windows, the Inkscape
> program shut down automatically when I click at Text> Text and Font,
> or clicking the Font dialogue box in Inkscape. The problem still
> exists after I have deleted the newly added font and even reinstalled
> Inkscape. I am sure the new fonts can work because I can use them
> without any problem in Microsoft Word.
>
> I have uploaded one of the font file for you to try at the link below,
> and also attached the same file here:
> https://www.filepicker.io/api/file/hYopCHUjS5uPU6tStIDd
>
> I am very frustrated now because I cannot even change English fonts,
> please offer help ASAP, thanks...
>
> To manage notifications about this bug go to:
> https://bugs.launchpad.net/inkscape/+bug/1508928/+subscriptions
>

su_v (suv-lp) on 2015-10-24
Changed in inkscape:
status: Incomplete → New
tags: added: win64
Patrick Storz (ede123) wrote :

I'm not able to reproduce the issue on Windows 10 x64 (de_DE locale) with Inkscape 0.92.1 r15371 (64-bit).

Maybe the issue was fixed? Could somebody who experienced this issue before check?

We had a related report at bug #1495386 (which I unfortunately was not able to reproduce either...).

Patrick Storz (ede123) wrote :

I just committed a potential fix for this issue:
http://bazaar.launchpad.net/~inkscape.dev/inkscape/trunk/revision/15687
http://bazaar.launchpad.net/~inkscape.dev/inkscape/0.92.x/revision/15428

I discovered that sometimes invalid characters were contained in the font name that caused all kinds of ugly problems. To avoid those Inkscape now checks for invalid characters in font names and refuses to load affected fonts (that means you won't be able to use them in Inkscape, but at least Inkscape should not crash anymore).

As I was never able to reproduce the crash on startup:
Could somebody who was affected by this issue please check if my changes prevent Inkscape from crashing? I uploaded a testing build of Inkscape 0.92.x (the stable branch) at [1].

[1]
https://download.tuxfamily.org/inkscape/win64/inkscape_0.92.x_r15429_win64_MSYS2.7z

Simon Li (simon-lsm) wrote :

 Hi Eduard,

I have uninstalled the original Inkscape 0.92.1, installed the same Chinese
fonts that I had uploaded to the forum some time ago (I am the one who
initiated the topic "Cannot add new Chinese fonts in Inkscape" in the
forum) and then opened your file. The Inkscape software can run run
smoothly without crash, so I think you have succeeded the prevent the
problem from happening. When I install the 0.92.1 again, it crashed and
cannot open, just like the 0.91 build. I may need to use FileZilla to
delete the font again if I need to use the 0.92.1 build.

Questions for you:
1. Can I continue to use this build? But I found that it doesn't require
installation and it is a bit slow.

2. Preventing from crashing is good, but I hope you can improve it a step
more to let the software displays the fonts that I added...

Thanks a lot.

Simon

「Eduard Braun <email address hidden>」在 2017年5月11日 週四,上午8:54 寫道:

> I just committed a potential fix for this issue:
> http://bazaar.launchpad.net/~inkscape.dev/inkscape/trunk/revision/15687
> http://bazaar.launchpad.net/~inkscape.dev/inkscape/0.92.x/revision/15428
>
> I discovered that sometimes invalid characters were contained in the
> font name that caused all kinds of ugly problems. To avoid those
> Inkscape now checks for invalid characters in font names and refuses to
> load affected fonts (that means you won't be able to use them in
> Inkscape, but at least Inkscape should not crash anymore).
>
> As I was never able to reproduce the crash on startup:
> Could somebody who was affected by this issue please check if my changes
> prevent Inkscape from crashing? I uploaded a testing build of Inkscape
> 0.92.x (the stable branch) at [1].
>
>
> [1]
>
> https://download.tuxfamily.org/inkscape/win64/inkscape_0.92.x_r15429_win64_MSYS2.7z
>
> --
> You received this bug notification because you are subscribed to the bug
> report.
> https://bugs.launchpad.net/bugs/1508928
>
> Title:
> Program crashed after adding new Chinese fonts
>
> Status in Inkscape:
> New
>
> Bug description:
> I am using Inkscape 0.91 on Windows 8.1, 64 bit.
>
> After I had added new Chinese fonts to the Windows, the Inkscape
> program shut down automatically when I click at Text> Text and Font,
> or clicking the Font dialogue box in Inkscape. The problem still
> exists after I have deleted the newly added font and even reinstalled
> Inkscape. I am sure the new fonts can work because I can use them
> without any problem in Microsoft Word.
>
> I have uploaded one of the font file for you to try at the link below,
> and also attached the same file here:
> https://www.filepicker.io/api/file/hYopCHUjS5uPU6tStIDd
>
> I am very frustrated now because I cannot even change English fonts,
> please offer help ASAP, thanks...
>
> To manage notifications about this bug go to:
> https://bugs.launchpad.net/inkscape/+bug/1508928/+subscriptions
>

Patrick Storz (ede123) wrote :

Hi Simon, great, that's some good news!

1. It's a build of the stable branch, so it should be safe to use. (There's one limitation: It's built with MSYS2 binaries which are still in testing, but at this point I'd say those builds are almost production ready while offering more features and also fixing some known bugs compared to "classic" builds).

If it's slower than the 0.92.1 release it's an unknown issue and I'd ask you report details ASAP.
If it's slower than the 0.91 release but performs the same as the 0.92.1 release there are some known performance regressions already filed as bugs (in this case you should check if the issue is already reported and if not open a new one specifying precisely what operations perform slower).

2. I'd love to do that, too. However I don't know much about pango/fontconfig (those are the libraries used by Inkscape to query the fonts installed on the system, and the issue might well originate there) or fonts in general, so it might not be easy.

Patrick Storz (ede123) wrote :

As the crash issue seems to be fixed I'm going to close this bug.

I filed a follow up bug for the remaining issue of actually being able to use the conflicting fonts that caused crashes before, see bug #1694326.

Changed in inkscape:
assignee: nobody → Eduard Braun (eduard-braun2)
status: New → Fix Committed
jazzynico (jazzynico) on 2017-05-30
Changed in inkscape:
importance: Undecided → High
milestone: none → 0.93
Qantas94Heavy (qantas94heavy) wrote :

Fix released in 0.92.2.

Changed in inkscape:
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers