PDF import options always default to 'Poppler/Cairo import' (rev >= 14170)

Bug #1506043 reported by su_v on 2015-10-14
8
This bug affects 1 person
Affects Status Importance Assigned to Milestone
Inkscape
Low
jazzynico

Bug Description

After the changes in Inkscape 0.91+devel rev 14170 (see also bug #1483701), PDF import options always default to import via poppler ("Poppler/Cairo import"). The last used setting is not remembered (neither in the current session, nor across sessions).

This is an unexpected change compared to current stable Inkscape 0.91 where the default is Inkscape's internal import (the user's choice is not remembered either): Apart from other differences in the resulting SVG structure, the major one is with text: import via 'Poppler/Cairo' produces outlined text ("converted to paths", reusing the glyphs of fonts embedded in the PDF file); implemented in SVG via symbols (per glyph) instanced as clones on-canvas (same as with the command line tool 'pdftocairo' from poppler). Without further changes, text from PDF files imported with default options will not editable as text in the next release (0.92).

Independent of whether or not the default import method is switched to external libraries (which might help resolving the build conflicts due to Inkscape requiring private poppler header files if Inkscape's internal import is dropped altogether), the last used choice of the user should be remembered (across sessions).

In case the setting ('Poppler/Cairo' or 'Internal') is restored from the preferences, the default used for command line operations, for example
$ inkscape -f file.pdf -l file.svg
likely needs to be reconsidered as well (currently, this PDF->SVG conversion via command line interface always uses Inkscape's internal import (no choice possible)).

su_v (suv-lp) on 2015-10-14
description: updated
jazzynico (jazzynico) wrote :

Confirmed on Xubuntu 15.04, Inkscape trunk rev. 14419.

Restoring the original default is an easy fix, but the PDF import code has a specific preference handling (Inkscape::XML::Node instead of Inkscape::Preferences) that seems to be broken.

Changed in inkscape:
status: New → Confirmed
jazzynico (jazzynico) wrote :

Partial patch (restore 0.91 import default).

jazzynico (jazzynico) wrote :

Well, it seems that SVG builder's preferences are not meant to be saved (and retrieved from) the preferences.xml file, but for internal use only.

su_v (suv-lp) on 2015-10-18
Changed in inkscape:
importance: Undecided → Low
jazzynico (jazzynico) wrote :

@Tav - As far as I understand your code (https://bazaar.launchpad.net/~inkscape.dev/inkscape/trunk/revision/14170), the change from internal to poppler for PDF imports doesn't seem to be intentional. Could you please confirm?

On Sun, 2015-10-18 at 17:05 +0000, jazzynico wrote:
> @Tav - As far as I understand your code
> (https://bazaar.launchpad.net/~inkscape.dev/inkscape/trunk/revision/1
> 4170),
> the change from internal to poppler for PDF imports doesn't seem to
> be
> intentional. Could you please confirm?

I did not intend to change the default. It can be switched to the
internal import.

jazzynico (jazzynico) wrote :

Default back to internal PDF import as of revision 14423.
I suggest we close the report and open a new one for the preferences issue.

Changed in inkscape:
status: Confirmed → In Progress
assignee: nobody → jazzynico (jazzynico)
tags: added: backport-proposed
tags: removed: backport-proposed
su_v (suv-lp) wrote :

On 2015-10-19 18:02 (+0200), jazzynico wrote:
> Default back to internal PDF import as of revision 14423. I suggest
> we close the report and open a new one for the preferences issue.

Agreed (I should not have mixed the two issues in the same report).

su_v (suv-lp) wrote :

Follow-up report filed:
* Bug #1507740 “Store/retrieve last used PDF import options via preferences”
  https://bugs.launchpad.net/inkscape/+bug/1507740

Changed in inkscape:
status: In Progress → Fix Committed
tags: removed: preferences
Bryce Harrington (bryce) on 2017-01-10
Changed in inkscape:
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers