Trace mode in Tiled Clones does not consider document scale

Bug #1502521 reported by su_v on 2015-10-03
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
Inkscape
Low
Mc

Bug Description

Using 'Trace' mode for Tiled Clones in a document with a different size of SVG user units (other than corresponding to 1 CSS pixel) produces incorrect result.

Steps to reproduce (see also attached test case):
1) launch current trunk (default new prefs, default new doc)
2) enable snap to page border
3) draw a rectangle 100x100mm, snapped to top left page corner
4) apply radial gradient (default)
5) draw a rectangle 10x10mm, snapped to top left page border
6) open 'Edit > Clone > Create Tiled Clones...'
7) in 'Trace' tab:
- [x] Trace the drawing under the tiles
- 1. Pick from the drawing: [o] Opacity
- 2. Tweak the picked value: <defaults>
- 3. Apply the value to the clones:
  [ ] Presence
  [x] Size
8) Rows, Columns: 10 x 10
9) Create
--> unexpected result, does not match the traced opacity
10) change Rows, Columns to: 38 x 38
11) Create
--> now the tiled clones trace the full radial gradient, but represented in a larger scale (* 3.77953)

Reproduced on OS X 10.7.5 with Inkscape 0.91 and 0.91+devel r14394.

Notes:
- The reported issue does not reproduce in a new document created from a 'px'-based template.
- This bug is more relevant for upcoming 0.92 than for 0.91 because the default templates in trunk have been switched to a different document scale (SVG user unit 'px' corresponds to 1 mm, not to 1 CSS pixel).

su_v (suv-lp) wrote :
Mc (mc...) on 2015-10-04
Changed in inkscape:
status: New → Fix Committed
importance: Undecided → Low
assignee: nobody → Mc (mc...)
su_v (suv-lp) wrote :

Fix committed in rev 14396.

tags: added: backport-proposed
su_v (suv-lp) wrote :

Fix backported to 0.91.x in rev 13840.

Changed in inkscape:
milestone: 0.92 → 0.91.1
tags: removed: backport-proposed
jazzynico (jazzynico) on 2017-01-28
Changed in inkscape:
milestone: 0.91.1 → 0.92
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers