win7 64bit Inkscape 0.91 start : encountered an internal error will be closed

Bug #1495386 reported by sunnyman on 2015-09-14
32
This bug affects 6 people
Affects Status Importance Assigned to Milestone
Inkscape
High
Patrick Storz
Nominated for 0.92.x by Patrick Storz

Bug Description

win8.1 64bit Inkscape 0.92.1 Inkscape has encountered an internal error and will close now
win7 64bit Inkscape0.9 Start Software : encountered an internal error will be closed
win7 32bit Inkscape0.9 Start Software : encountered an internal error will be closed

jazzynico (jazzynico) on 2015-09-14
summary: - win7 64bit Inkscape0.9 Start encountered an internal error will be
+ win7 64bit Inkscape 0.91 start : encountered an internal error will be
closed
tags: added: crash win32 win64
jazzynico (jazzynico) wrote :

Hello sunnyman, and thanks for your report.

Could you please give some more details:
- did you install Inkscape with the MSI package, the .exe installer or the 7zip archive?
- did you ever managed to launch Inkscape?

In the report you wrote Inkscape 0.9, but I guess you mean 0.91 (0.9 doesn't exist).

Changed in inkscape:
importance: Undecided → High
status: New → Incomplete
Hachmann (marenhachmann) wrote :

Sounds like that recent question in our answers section: https://answers.launchpad.net/inkscape/+question/271329

Huang Yaoting (hit1205) wrote :

I have same problem when I running Inkscape 0.92.1 on Win 7 Ultimate (64bit).
(installed by the 7zip archive)

If I start Inkscape with "inkscape.com", it output those warning messages:
http://pastebin.com/raw/BGSG1RCj

I have solved the problem after I read this thread:
http://www.inkscapeforum.com/viewtopic.php?t=18421

I have 28 fonts with non-English filename (they're in Chinese),
Inkscape running correctly after I remove them...

Maybe Inkscape doesn't recognized fonts with non-English filename in Windows?

jazzynico (jazzynico) wrote :

@Huang Yaoting - Thanks for your investigations and workaround! We have a lot of "Windows crashed at startup" like bug reports, an some of them could well be related to the same cause.

@sunnyman - Could you please tell us if you're using fonts with non-English characters so that we can confirm it's the same issue Huang Yaoting has.

Patrick Storz (ede123) wrote :

I'm not able to reproduce the bug on Windows 10 x64 using Inkscape Inkscape 0.92.1 r15371 (64 bit).
- Fonts with Chinese font name are shown but don't seem to be selectable in Inkscape
- Fonts with Chinese file name are not shown in Inkscape at all

I did similar tests with fonts containing umlauts (äöü) as those can be displayed in my systems character encoding:
- They are shown and can be used in Inkscape

That being said I doubt the file name of a font should ever contain non-ANSI characters. Even Windows 10's native font manager fails to list them.

Patrick Storz (ede123) wrote :

Likely related to / duplicate of bug #1508928.

jazzynico (jazzynico) wrote :

@Huang Yaoting - Could you please give an example of Chinese fonts that crash the application so that we can test and try to reproduce? Thanks!

description: updated
Patrick Storz (ede123) wrote :

I just committed a potential fix for this issue:
http://bazaar.launchpad.net/~inkscape.dev/inkscape/trunk/revision/15687
http://bazaar.launchpad.net/~inkscape.dev/inkscape/0.92.x/revision/15428

I discovered that sometimes invalid characters were contained in the font name that caused all kinds of ugly problems. To avoid those Inkscape now checks for invalid characters in font names and refuses to load affected fonts (that means you won't be able to use them in Inkscape, but at least Inkscape should not crash anymore).

As I was never able to reproduce the crash on startup:
Could somebody who was affected by this issue please check if my changes prevent Inkscape from crashing? I uploaded a testing build of Inkscape 0.92.x (the stable branch) at [1].

[1]
https://download.tuxfamily.org/inkscape/win64/inkscape_0.92.x_r15429_win64_MSYS2.7z

Patrick Storz (ede123) wrote :

For historical reasons (and for a request at the Pango mailing list) I'm attaching another font which caused crashes here.

Patrick Storz (ede123) wrote :

gdb backtrace for future reference

Julian Ragan (julianragan) wrote :

I confirm, your build has solved the issue I had with running Inkscape on my system.

Cheers.

Patrick Storz (ede123) wrote :

As the crash issue seems to be fixed I'm going to close this bug.

I filed a follow up bug for the remaining issue of actually being able to use the conflicting fonts that caused crashes before, see bug #1694326.

Changed in inkscape:
assignee: nobody → Eduard Braun (eduard-braun2)
status: Incomplete → Fix Committed
jazzynico (jazzynico) on 2017-05-30
Changed in inkscape:
milestone: none → 0.93
qubodup (qubodup) wrote :

I experienced this error message recently. Wiping preferences and font cache had no effect neither did reinstalling. (I did not try wiping registry). It was resolved by restarting Windows.

I can't know for sure but it seems that it was caused by installing ESET NOD32 Antivirus and not restarting Windows 10.

Perhaps the antivirus was preventing some dll files from being used.

Changed in inkscape:
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers