Rubberband Selector Box Doesn't Contrast (Node tool, 0.91)

Bug #1494445 reported by David on 2015-09-10
8
This bug affects 1 person
Affects Status Importance Assigned to Milestone
Inkscape
Low
Alvin Penner

Bug Description

OS: Linux (Ubuntu 15.04 Vivid)

inkscape --version
Inkscape 0.91 r13725 (Feb 19 2015)

Occurs when: Using the "Edit paths by nodes" tool

While dragging the cursor to select objects, the rubberband box does not appear as a contrasting box. It appears as a solid black box.

This behavior DOES NOT occur while using the "Select and transform objects" tool, and it contrasts normally.

To replicate the problem:

Simply drag the cursor while holding the left mouse button while the "edit paths by nodes" tool is active over the drawing area, the box that indicates the selection area will remain black regardless of color beneath it.

David (logicphase) on 2015-09-10
tags: added: box edit paths selection
su_v (suv-lp) on 2015-09-10
summary: - Rubberband Selector Box Doesn't Contrast On Linux
+ Rubberband Selector Box Doesn't Contrast (Node tool, 0.91)
tags: added: node-editing ui
removed: box edit paths
tags: added: regression
su_v (suv-lp) wrote :

On OS X 10.7.5:
- not reproduced with Inkscape 0.47, 0.48.5
- reproduced with Inkscape 0.91 r13725 and 0.91+devel r14353.

Based on tests with archived builds:
- not reproduced with 0.48+devel r10325,
- reproduced with 0.48+devel r10326;
this regression was introduced with the merge of the new cairo-based renderer in revision 10326 which no longer supports XOR mode.

For the selection tool (F1), this was fixed in rev 12936 (for bug 1266308):
https://bazaar.launchpad.net/~inkscape.dev/inkscape/trunk/revision/12936

@Alvin - any chance you could apply the same solution for the node tool selection frame?

Changed in inkscape:
importance: Undecided → Low
milestone: none → 0.92
status: New → Confirmed
Alvin Penner (apenner) wrote :

yes, I can take a look at it...

Alvin Penner (apenner) wrote :

fix committed to rev 14358

Changed in inkscape:
status: Confirmed → Fix Committed
su_v (suv-lp) on 2015-09-12
Changed in inkscape:
assignee: nobody → Alvin Penner (apenner)
su_v (suv-lp) on 2015-09-14
tags: added: backport-proposed
su_v (suv-lp) wrote :

Fix backported to 0.91.x in rev 13814.

Changed in inkscape:
milestone: 0.92 → 0.91.1
tags: removed: backport-proposed
jazzynico (jazzynico) on 2017-01-28
Changed in inkscape:
milestone: 0.91.1 → 0.92
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers